Bug 820402 - fence_ifmib and fence_intelmodular disappeared from the fence device list
fence_ifmib and fence_intelmodular disappeared from the fence device list
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 16:08 EDT by Ryan McCabe
Modified: 2012-06-20 08:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: luci-0.26.0-12.el6
Doc Type: Bug Fix
Doc Text:
Cause: Between RHEL 6.1 and RHEL 6.2, a regression occurred that resulted in the Intel Modular and IF MIB fencing agents being removed from the list of devices for which users could configure new instances. Consequence: Users could not create a new instance of an Intel Modular or IF MIB fencing device. They would still have been able to make changes to existing entries. Fix: The Intel Modular and IF MIB fencing device entries have been added back to the list of fence devices. Result: Users are again able to create new instances of Intel Modular and IF MIB fencing devices.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:18:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (1.59 KB, patch)
2012-05-09 16:15 EDT, Ryan McCabe
no flags Details | Diff

  None (edit)
Description Ryan McCabe 2012-05-09 16:08:07 EDT
Between RHEL 6.1 and RHEL 6.2 the entries for the IF MIB and the Intel Modular fencing agents disappeared from the list of fencing agents that users can select to configure.

As a result, users using a version of luci more recent than the RHEL 6.1 release (luci-0.23.0-13.el6) can not create new instances of these fence agents via luci.
Comment 1 Ryan McCabe 2012-05-09 16:15:22 EDT
Created attachment 583379 [details]
Fix
Comment 8 Ryan McCabe 2012-05-14 15:32:01 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Between RHEL 6.1 and RHEL 6.2, a regression occurred that resulted in the Intel Modular and IF MIB fencing agents being removed from the list of devices for which users could configure new instances.

Consequence: Users could not create a new instance of an Intel Modular or IF MIB fencing agent. They would still have been able to make changes to existing entries.

Fix: The Intel Modular and IF MIB fencing agents have been added back to the list of fence devices.

Result: Users are again able to create new instances of Intel Modular and IF MIB fencing agents.
Comment 9 Ryan McCabe 2012-05-14 15:33:02 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,7 @@
 Cause: Between RHEL 6.1 and RHEL 6.2, a regression occurred that resulted in the Intel Modular and IF MIB fencing agents being removed from the list of devices for which users could configure new instances.
 
-Consequence: Users could not create a new instance of an Intel Modular or IF MIB fencing agent. They would still have been able to make changes to existing entries.
+Consequence: Users could not create a new instance of an Intel Modular or IF MIB fencing device. They would still have been able to make changes to existing entries.
 
-Fix: The Intel Modular and IF MIB fencing agents have been added back to the list of fence devices.
+Fix: The Intel Modular and IF MIB fencing device entries have been added back to the list of fence devices.
 
-Result: Users are again able to create new instances of Intel Modular and IF MIB fencing agents.+Result: Users are again able to create new instances of Intel Modular and IF MIB fencing devices.
Comment 16 errata-xmlrpc 2012-06-20 08:18:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0766.html

Note You need to log in before you can comment on or make changes to this bug.