Bug 820442 - 'service lm_sensors status' is returning a bad error code
'service lm_sensors status' is returning a bad error code
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lm_sensors (Show other bugs)
5.8
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jaromír Cápík
BaseOS QE - Apps
:
Depends On:
Blocks: 1002709
  Show dependency treegraph
 
Reported: 2012-05-09 19:29 EDT by Nilesh Parmar
Modified: 2016-01-31 20:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:37:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nilesh Parmar 2012-05-09 19:29:24 EDT
Description of problem:
'service lm_sensors status' is returning a bad error code

Version-Release number of selected component (if applicable):
lm_sensors

How reproducible:


Steps to Reproduce:
1.# /etc/init.d/lm_sensors stop
 # /etc/init.d/lm_sensors status
2.# echo $? (gives 0) 

3.# /etc/init.d/lm_sensors start
  # /etc/init.d/lm_sensors status
  # echo $? (gives 0)

Actual results:
exit status return code gives zero when service stop

Expected results:
exit status return code should give non-zero when service stop

Additional info:
other services like vsftpd give non-zero exit status when service stop while exit status is zero when service start

[root@sv0143 ~]# /etc/init.d/cpuspeed status
cpuspeed is stopped
[root@sv0143 ~]# echo $?
3
[root@sv0143 ~]# /etc/init.d/lm_sensors status
[root@sv0143 ~]# echo $?
0
Comment 1 RHEL Product and Program Management 2013-05-01 03:20:29 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Andrius Benokraitis 2013-10-06 21:37:24 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.