Bug 820458 - Yum update fails
Yum update fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 22:02 EDT by thanosk
Modified: 2014-01-21 18:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 16:38:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum transaction log (33.80 KB, text/plain)
2012-05-09 22:15 EDT, thanosk
no flags Details

  None (edit)
Description thanosk 2012-05-09 22:02:07 EDT
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20100101 Firefox/12.0

yum update fails due to a transaction check

Reproducible: Always

Steps to Reproduce:
1.Yum update
2.
3.
Actual Results:  
ERROR with transaction check vs depsolve:
python(abi) = 2.6 is needed by (installed) python-psyco-1.6-4.fc12.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
python-psyco-1.6-4.fc12.i686 has missing requires of libpython2.6.so.1.0
python-psyco-1.6-4.fc12.i686 has missing requires of python(abi) = ('0', '2.6', None)
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-05-09.18-47.3lUSpm.yumtx
Comment 1 thanosk 2012-05-09 22:15:48 EDT
Created attachment 583413 [details]
yum transaction log
Comment 2 James Antill 2012-05-10 16:38:17 EDT
 As it says, there are pre-existing problems in your rpmdb. You need to use remove/install/reinstall to fix them before doing new transactions.

Note You need to log in before you can comment on or make changes to this bug.