Bug 820475 - "abrt-ccpp status" returned no status messages
"abrt-ccpp status" returned no status messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.3
i686 Linux
unspecified Severity low
: rc
: ---
Assigned To: Denys Vlasenko
Iveta Wiedermann
:
: 854623 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 01:52 EDT by masanari iida
Modified: 2013-02-21 02:53 EST (History)
9 users (show)

See Also:
Fixed In Version: abrt-2.0.8-7.el6
Doc Type: Bug Fix
Doc Text:
Cause: No status messages was emitted from the abrt-ccpp init script Consequence: Running command $ service abrt-ccpp status didn't show any message, so user can't check the status of the service Fix: Add code which emits message describing the current status of the service. Result: The output of the command $ service abrt-ccpp status is now: [root@localhost ~]# service abrt-ccpp status abrt-ccpp hook is installed [root@localhost ~]# service abrt-ccpp stop [root@localhost ~]# service abrt-ccpp status abrt-ccpp hook is not installed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:53:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2012-05-10 01:52:23 EDT
Description of problem:
/etc/init.d/abrt-ccpp status returns nothing because
of verbose=false setting in /usr/sbin/abrt-install-ccpp-hook.


Version-Release number of selected component (if applicable):
abrt-2.0.8-4.el6 (from RHEL6.3 beta)
abrt-addon-ccpp-2.0.8-4.el6. (from RHEL6.3 beta)

How reproducible:
Always


Steps to Reproduce:
1. Install RHEL6.3 beta
2. Login to the system with root user
3. Check abrtd is running  ( ps ax |grep abrt) 
   This one is auto starting while booting the OS.
4. Manually start abrt-ccpp ( # /etc/init.d/abrt-ccpp start)
5. Manually check abrt-ccpp is running or not. (# /etc/init.d/abrt-ccpp status)
  
Actual results:
It returns nothing.

Expected results:
Some messages which indicates abrt-ccpp is working or not should be display.

Additional info:
After modify verbose=false to true in /usr/sbin/abrt-install-ccpp-hook,
either "Installed" or "Not installed" are display.

From user's point of view, I wanted to checkout what kind of process is running 
for abrt-ccpp servoce , and try " ps ax |grep abrt" but I couldn't find 
the "abrt-ccpp" daemon. And "abrt-ccpp status" returns nothing. 
This is very confused. 
Then I followed the script and learned that the script "installed" the hook,
instead of starting some daemon.

I hope this is documented somewhere (ex. Update Deployment Guide or KB.)
If we can find the good documentation, I don't request to modify the default
setting. (And ask the customer to read the manual before making a question.)

Business impact: None
Comment 2 RHEL Product and Program Management 2012-05-14 00:04:33 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 04:32:05 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 19:03:16 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Denys Vlasenko 2012-07-29 16:20:37 EDT
Fixed in git:

commit da9a95a08fa6f4d566101ebbe2bc457dfc4ea0f2
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Sun Jul 29 22:19:29 2012 +0200

    Make "abrt-ccpp status" tell user whether hook is currently installed
Comment 9 Jakub Filak 2012-09-05 10:13:32 EDT
*** Bug 854623 has been marked as a duplicate of this bug. ***
Comment 13 errata-xmlrpc 2013-02-21 02:53:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0290.html

Note You need to log in before you can comment on or make changes to this bug.