Bug 820492 - automounts don't expire
automounts don't expire
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 03:28 EDT by Matthias Runge
Modified: 2012-05-11 04:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 04:23:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2012-05-10 03:28:50 EDT
Description of problem:
May 10 08:55:48 mrungexp automount[6986]: expiring path /misc/itdienste
May 10 08:57:31 mrungexp automount[6986]: mounted /misc/itdienste
May 10 08:58:18 mrungexp automount[6986]: 1 remaining in /misc
May 10 08:59:33 mrungexp automount[6986]: 1 remaining in /misc
May 10 09:00:48 mrungexp automount[6986]: 1 remaining in /misc



[root@mrungexp conf.d]# fuser /misc
/misc:                6986
[root@mrungexp conf.d]# ps ax | grep 6986
 6986 ?        Ssl    0:01 /usr/sbin/automount --verbose --pid-file /run/autofs.pid
28896 pts/0    S+     0:00 grep --color=auto 6986


Looks like, automount blocks itself from unmounting.


Version-Release number of selected component (if applicable):
autofs-5.0.6-16.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. mount a directory via automounter
2. make sure, the dir is not used
Comment 1 Ian Kent 2012-05-10 08:06:38 EDT
I had a problem where automounts weren't expiring for a while
on F16. I was mystified by it and couldn't work out what was
causing it after trying everything I could.

All the evidence seemed to point to something in user space
causing the reference count on mount points to be elevated
by one, which stopped the mount expiring but I couldn't find
any kernel facility that would cause that. This only happened
when the Gnome GUI was active, rebooting into run level 3
made everything work fine and building several kernels that
I had previously used when testing had the same problem.

Very odd.

I did a yum update today and the problem has gone away.
I still don't know what caused it.

I have a vm with the F17 beta installed on it which was
yum updated on Friday and a simple test shows that it is
functioning OK.

There is another possibility and that is a monitoring
system may be causing the last used value to be updated
thereby causing the mount to be see as recently used.

You need to check if anything like that is happening on
your system.
Comment 2 Matthias Runge 2012-05-11 04:23:25 EDT
Hmm, after doing an update today and rebooting, it looks good for me. Thank you!

Note You need to log in before you can comment on or make changes to this bug.