Bug 820547 - PATCH: Adding support for openldap-servers-perl
PATCH: Adding support for openldap-servers-perl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 07:20 EDT by David Dick
Modified: 2013-05-06 09:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: openldap-2.4.34-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 09:26:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adds support for openldap-servers-perl (1.62 KB, patch)
2012-05-10 07:20 EDT, David Dick
no flags Details | Diff

  None (edit)
Description David Dick 2012-05-10 07:20:53 EDT
Created attachment 583511 [details]
Adds support for openldap-servers-perl

Description of problem:

There is no current support for the perl backend of openldap

Version-Release number of selected component (if applicable):

2.4.29-2

Additional info:

This patch adds support for the perl backend
Comment 1 Jan Vcelak 2012-05-29 05:28:29 EDT
We are thinking about this. ;-)
Comment 2 David Dick 2012-09-17 07:06:01 EDT
I'd like to get the perl backend working in fedora.  If you don't want to let the patch through, can you discuss what the problem is?
Comment 3 Jan Vcelak 2012-09-19 05:52:39 EDT
Sorry, but I really know about this report.

The problem is rather a political. According to the documentation, the backend is primarily intended for prototyping. And I'm not sure if this brings any pitfails. And I haven't decided if this belongs to a separate subpackage.

There are still some important fixes I want to get into F18. And I want to have the git branch synced with Rawhide branch as long as possible. So, please, wait till the F18 is out. Then I will enable the perl backend both in F18 and Rawhide and we can get some feedback via updates-testing. No experiments for now. :-)

Jan
Comment 4 Fedora Admin XMLRPC Client 2013-01-30 06:10:47 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Update System 2013-03-11 09:47:02 EDT
openldap-2.4.34-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openldap-2.4.34-1.fc18
Comment 7 Fedora Update System 2013-03-26 20:44:39 EDT
openldap-2.4.34-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Gregory Lee Bartholomew 2013-05-02 17:29:02 EDT
FYI, I got the following error in /var/log/messages when I tried to start slapd.service with perl enabled:

May  2 15:14:25 node-02 check-config.sh[14958]: 5182c921 /etc/openldap/slapd.conf: line 22: error Can't load '/usr/lib64/perl5/auto/Fcntl/Fcntl.so' for module Fcntl: /usr/lib64/perl5/auto/Fcntl/Fcntl.so: undefined symbol: PL_thr_key at /usr/share/perl5/XSLoader.pm line 68.

I found that adding the line:

LD_PRELOAD=/usr/lib64/perl5/CORE/libperl.so

to /etc/sysconfig/slapd seems to have resolved the problem.

I'm using Fedora 18

rpm -q openldap-servers
openldap-servers-2.4.34-1.fc18.x86_64
Comment 9 Jan Synacek 2013-05-06 04:33:55 EDT
(In reply to comment #8)
> FYI, I got the following error in /var/log/messages when I tried to start
> slapd.service with perl enabled:
> 
> May  2 15:14:25 node-02 check-config.sh[14958]: 5182c921
> /etc/openldap/slapd.conf: line 22: error Can't load
> '/usr/lib64/perl5/auto/Fcntl/Fcntl.so' for module Fcntl:
> /usr/lib64/perl5/auto/Fcntl/Fcntl.so: undefined symbol: PL_thr_key at
> /usr/share/perl5/XSLoader.pm line 68.

I consulted this with the perl maintainer. Slapd seems to be using dlopen() to load /usr/lib64/perl5/auto/Fcntl/Fcntl.so, which is a perl plugin that assumes that the libperl.so is already loaded.

Do you use your own perl installation, or the one that's included in Fedora?

Also, could you provide a reproducer?
Comment 10 Jan Synacek 2013-05-06 09:43:04 EDT
Follow up in bug 960048.

Note You need to log in before you can comment on or make changes to this bug.