Bug 82056 - Phoebe Swedish keyboard layout cannot type "bar/pipe"
Summary: Phoebe Swedish keyboard layout cannot type "bar/pipe"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: phoebe
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-16 22:09 UTC by Henrik Nordstrom
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 23:11:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrik Nordstrom 2003-01-16 22:09:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
The swedish keyboard layout is missing "bar/pipe" from the "less/greater/bar"
button (between lshift and z)

When you press Alt-GR + less/greater/bar you are supposed to get a "bar", but in
Phoebe you get a < as if Alt-Gr was not used.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Find a computer with the less/greater/bar button between shift and z (keycode 94)
2. Try to type a pipe

    

Actual Results:  Alt-Gr is "ignored" and results in a < 

Expected Results:  A pipe/bar

Additional info:

I am downloading the Rawhide XFree86 packages in hope that this annoying problem
is fixed. If not I will have to reinstall RedHat 8.0 until a fix is available as
it is impossible to program without the pipe, and it does not seem to help
adding the bar using xmodmap.. (I assume the xmodmap issue is a sideeffect from
the use of ISO_Level3_Shift for the Alt-GR key, never really understood these
level shift magic keys)

Comment 1 Henrik Nordstrom 2003-01-16 22:11:24 UTC
XFree86-4.2.99.2-0.20021217.0


Comment 2 Henrik Nordstrom 2003-01-16 23:11:39 UTC
Upgrade to rawhide XFree86 packages fixed the missing bar/pipe syndrom. Many thanks.

But all of a sudden the mousepointer is red. Don't know it it is due to me
fiddling around with the preferences, or something with the RawHide XFree86. In
any case if the red curstor is a bug it is another one not belonging in this bug
report..

I consider this bug closed, but you should probably modify the version to Phoebe
as it is not relevant to 8.0.


Note You need to log in before you can comment on or make changes to this bug.