Bug 820603 - [abrt] kernel: [162276.196730] BUG: Bad page state in process transmission-gt pfn:1bddff
[abrt] kernel: [162276.196730] BUG: Bad page state in process transmission-gt...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:c75e704774880c28b3d40989913...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 09:01 EDT by Serge Pavlovsky
Modified: 2012-07-16 18:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 18:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (4.38 KB, text/plain)
2012-05-10 09:01 EDT, Serge Pavlovsky
no flags Details

  None (edit)
Description Serge Pavlovsky 2012-05-10 09:01:04 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.4-3.fc16.x86_64 root=UUID=767aaff4-775e-49cd-a068-0cd1a6576716 ro LANG=ru_RU.UTF-8 rd.md=0 rd.lvm=0 rd.dm=0 quiet rhgb rd.luks=0 radeon.pcie_gen2=1 KEYTABLE=ru
kernel:         3.3.4-3.fc16.x86_64
reason:         [162276.196730] BUG: Bad page state in process transmission-gt  pfn:1bddff
time:           Чтв 10 Май 2012 15:58:14

smolt_data:     Binary file, 4488 bytes

backtrace:
:[162276.196730] BUG: Bad page state in process transmission-gt  pfn:1bddff
:[162276.196735] page:ffffea0006f77fc0 count:0 mapcount:0 mapping:          (null) index:0x7f2fdb962
:[162276.196737] page flags: 0x40000000000014(referenced|dirty)
:[162276.196741] Modules linked in: tcp_lp ppdev parport_pc lp parport pppoe pppox ppp_generic slhc rfcomm ebtable_nat ebtables xt_CHECKSUM bridge stp llc lockd be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi bnep it87 hwmon_vid ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state ipt_MASQUERADE ip6table_filter iptable_nat nf_nat ip6_tables nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 xt_TCPMSS iptable_mangle fuse snd_hda_codec_hdmi snd_hda_codec_realtek joydev btusb bluetooth edac_core edac_mce_amd serio_raw rfkill microcode k10temp snd_ctxfi snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device binfmt_misc sp5100_tco i2c_piix4 snd_pcm r8169 mii snd_timer snd soundcore snd_page_alloc vhost_net macvtap macvlan tun virtio_net kvm_amd kvm uinput sunrpc btrfs zlib_deflate libcrc32c mxm_wmi firewire_ohci firewire_core crc_itu_t wmi radeo
:n ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:[162276.196807] Pid: 2773, comm: transmission-gt Not tainted 3.3.4-3.fc16.x86_64 #1
:[162276.196809] Call Trace:
:[162276.196817]  [<ffffffff811279af>] bad_page+0xbf/0x110
:[162276.196821]  [<ffffffff811290d0>] get_page_from_freelist+0x6e0/0x8b0
:[162276.196825]  [<ffffffff813f671a>] ? ahci_qc_prep+0x13a/0x190
:[162276.196828]  [<ffffffff813e42e0>] ? ata_scsiop_mode_sense+0x330/0x330
:[162276.196832]  [<ffffffff81129565>] __alloc_pages_nodemask+0x125/0x8f0
:[162276.196836]  [<ffffffff812a4b1c>] ? blk_peek_request+0x1cc/0x230
:[162276.196839]  [<ffffffff8139d3c7>] ? put_device+0x17/0x20
:[162276.196842]  [<ffffffff813c2ca1>] ? scsi_request_fn+0xd1/0x470
:[162276.196846]  [<ffffffff811608d3>] alloc_pages_current+0xa3/0x110
:[162276.196849]  [<ffffffff81120777>] __page_cache_alloc+0x97/0xa0
:[162276.196852]  [<ffffffff8112c4f3>] __do_page_cache_readahead+0xf3/0x270
:[162276.196855]  [<ffffffff8112c951>] force_page_cache_readahead+0x71/0xa0
:[162276.196858]  [<ffffffff81124c3f>] sys_fadvise64_64+0x1af/0x230
:[162276.196861]  [<ffffffff81124cce>] sys_fadvise64+0xe/0x10
:[162276.196864]  [<ffffffff815fbee9>] system_call_fastpath+0x16/0x1b
:[162276.196866] Disabling lock debugging due to kernel taint
Comment 1 Serge Pavlovsky 2012-05-10 09:01:09 EDT
Created attachment 583553 [details]
File: smolt_data
Comment 2 Dave Jones 2012-07-16 15:17:46 EDT
reproducable ? still a problem on 3.4 ?

if so, give memtest86 a try just to rule out hardware problems.
Comment 3 Serge Pavlovsky 2012-07-16 17:47:59 EDT
no more abrt reports since first one
Comment 4 Dave Jones 2012-07-16 18:26:55 EDT
hmm. ok, I don't have a good explanation for it, but please do let us know if it happens again.

thanks.

Note You need to log in before you can comment on or make changes to this bug.