Bug 820637 - Add grub2 theming
Add grub2 theming
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F17-accepted/F17FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-05-10 10:48 EDT by Tom "spot" Callaway
Modified: 2012-05-18 19:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-17.27-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 19:02:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2012-05-10 10:48:56 EDT
Grub2 in Fedora 16 was ugly, black, and spartan, with the reasoning given that the default was for it to have a 0 timeout, thus never be seen anyways.

Well, plenty of people still see it, so Mo Duffy generated a theme. The background for that theme is in fedora-logos-17.0.2-1.fc17. We'd also need grub2-2.0-0.25.beta4.fc17 for the rest of the theming (menu layout, colors, etc).
Comment 1 Adam Williamson 2012-05-10 11:24:18 EDT
+1 NTH. I don't think adding a theme is likely to be a dangerous change. the apparent change to 'graphical mode', if anything, would be the dangerous change, but that seems to have already landed. so taking the theme on top isn't really likely to hurt anything, and makes it all look nicer.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2012-05-10 11:24:58 EDT
as always, though, I _do_ wish we could get these changes in earlier. there was plenty of opportunity to land changes to the bootloader earlier.
Comment 3 Adam Williamson 2012-05-10 18:35:04 EDT
Doesn't this also need a change to anaconda to write the GRUB_THEME line?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Tom "spot" Callaway 2012-05-11 09:36:49 EDT
I believe that the answer here is no, because /etc/default/grub will have the proper setting. Peter would know for sure though.
Comment 5 Dennis Gilmore 2012-05-11 22:15:48 EDT
+1 nth, having a pretty bootloader is nice
Comment 6 Andre Robatino 2012-05-11 22:42:53 EDT
+1 NTH
Comment 7 John Dulaney 2012-05-11 23:07:02 EDT
+1 NTH if it doesn't break the world
Comment 8 Adam Williamson 2012-05-11 23:40:35 EDT
spot: well, I tested a live image with the updated grub2 and fedora-logos, and it still wasn't themed after install.

Accepted as NTH with the above votes.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Tom "spot" Callaway 2012-05-12 07:21:48 EDT
Hmm. Peter, any ideas?
Comment 10 Bruno Wolff III 2012-05-13 09:30:46 EDT
+1 NTH as it affects installs and is unlikely to break things in a not clearly visible manner.
Comment 11 Peter Jones 2012-05-15 10:41:08 EDT
This is fixed in anaconda-17.27-1 :

* Mon May 14 2012 Brian C. Lane <bcl@redhat.com> - 17.27-1
- anaconda-cleanup: umount /run/media too (#820750) (bcl)
- Disable md /boot and /boot/efi on EFI. (#816823) (dlehman)
- dracut: use nfs3 by default (#811242) (wwoods)
- script.py error message needs gettext (bcl)
- We have a grub2 theme now, so say to use it. (pjones)
Comment 12 Adam Williamson 2012-05-15 11:39:57 EDT
Setting VERIFIED, as tflink mentioned on IRC last night he'd seen the new theme on an install from his test ISO. I'll confirm with TC6 also.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Adam Williamson 2012-05-18 19:02:52 EDT
17.27 went stable. closing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.