Bug 820647 - HP WGBU 6.3: i915 apparently does not recognize Enterprise Ivy Bridge graphics (E3-xxxx CPUs)
HP WGBU 6.3: i915 apparently does not recognize Enterprise Ivy Bridge graphi...
Status: CLOSED DUPLICATE of bug 817926
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks: 728567
  Show dependency treegraph
 
Reported: 2012-05-10 11:06 EDT by Jeff Burrell
Modified: 2012-05-10 11:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 11:24:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burrell 2012-05-10 11:06:40 EDT
Installing RHEL 6.3 beta/ss1 (64-bit, legacy-mode boot) on Ivy Bridge / Panther Point system(HP Z220), the Intel DRM and X server support is active if the processor is a desktop-class Core CPU, e.g. i7-3770.  

But if the CPU is an enterprise-class processor (e.g. E3-1245v2), the i915
kernel module is not loaded and the installation sets up the X server for the
fbdev driver.

Modifying xorg.conf to require the intel video driver just leads to the
Xorg.0.log file that is attached.  Also attaching lspci -vv output for the
graphics device.

It appears that the PCI ID for the E3 processors are missing.

Reproducible: Always

Steps to Reproduce:
1. Acquire a system (would be a prototype at the time of this submittal) with
an E3-class Ivy Bridge CPU that has Intel HD graphics support.
2. Install RHEL 6.3 in legacy BIOS mode (though UEFI would probably act the
same).
3. Log in and check the status of the i915 DRM support and the X server
configuration. 
Actual Results:  
Since the native Intel graphics support is not active, resolutions are limited
for the display, and GL support is via MESA.  Performance is less than
expected.  Desktop effects are not enabled by default because they cannot
perform using the frame buffer driver.

Expected Results:  
The KMS and X server support for the processor should be available.  Desktop
effects should be on by default.

We submitted almost exactly the same bug to SuSE recently.  They found the upstream commit where Intel added the missing ID:

The ID was added to 3.4-rc2 via commit cc22a938fc1db0c8ef5e693a69b159c4b851dab3
  From: Eugeni Dodonov <eugeni.dodonov@intel.com>
  Date: Thu, 29 Mar 2012 20:55:48 -0300
  Subject: [PATCH] drm/i915: add Ivy Bridge GT2 Server entries
Comment 2 Prarit Bhargava 2012-05-10 11:24:00 EDT

*** This bug has been marked as a duplicate of bug 817926 ***

Note You need to log in before you can comment on or make changes to this bug.