Bug 820653 - OSError: [Errno 12] Cannot allocate memory
OSError: [Errno 12] Cannot allocate memory
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:be7942de961d044d1648ab33dc2...
:
Depends On:
Blocks: 722280
  Show dependency treegraph
 
Reported: 2012-05-10 11:22 EDT by Abdel Sadek
Modified: 2013-01-10 01:46 EST (History)
7 users (show)

See Also:
Fixed In Version: Fedora 17 GA
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-12 12:56:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-5yu_J3 (138.39 KB, text/plain)
2012-05-10 11:22 EDT, Abdel Sadek
no flags Details

  None (edit)
Description Abdel Sadek 2012-05-10 11:22:12 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-5yu_J3
hashmarkername: anaconda
kernel:         3.3.0-1.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Thu 10 May 2012 09:16:45 AM UTC
version:        17-Beta

anaconda-tb-5yu_J3: Text file, 141709 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.20 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/subprocess.py", line 1130, in _execute_child
:    self.pid = os.fork()
:  File "/usr/lib64/python2.7/subprocess.py", line 679, in __init__
:    errread, errwrite)
:  File "/usr/lib64/python2.7/subprocess.py", line 493, in call
:    return Popen(*popenargs, **kwargs).wait()
:  File "/usr/lib/python2.7/site-packages/system_config_keyboard/keyboard.py", line 163, in activate
:    call (argv)
:  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 217, in getNext
:    self.kbd.activate()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/kbd_gui.py", line 37, in getNext
:    installKeyboardWindow.getNext(self)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1197, in nextClicked
:    rc = self.currentWindow.getNext ()
:OSError: [Errno 12] Cannot allocate memory

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.2BZA7i
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Abdel Sadek 2012-05-10 11:22:15 EDT
Created attachment 583614 [details]
File: anaconda-tb-5yu_J3
Comment 2 Abdel Sadek 2012-05-10 11:38:13 EDT
The issue was encountered while trying to install Fedora 17 Beta on an IBM 3650 M3 server.
Comment 3 Chris Lumens 2012-05-14 10:30:39 EDT
That's a pretty strange error.  If you can reproduce it, can you switch to tty2 and see how much memory is free when the error occurs?
Comment 5 Abdel Sadek 2012-06-12 09:15:23 EDT
The issue was initially encountered using Fedora 17 Beta. After using Fedora 17 GA version, I was not able to reproduce it.

Note You need to log in before you can comment on or make changes to this bug.