Bug 820661 - [abrt] kernel: WARNING: at fs/dcache.c:2537 prepend_path+0x1c9/0x1e0()
[abrt] kernel: WARNING: at fs/dcache.c:2537 prepend_path+0x1c9/0x1e0()
Status: CLOSED DUPLICATE of bug 766277
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:b31290bfb939c6ae54cb4eb1c34...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 11:35 EDT by Emmett Culley
Modified: 2012-05-10 11:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 11:50:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmett Culley 2012-05-10 11:35:19 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.4-3.fc16.x86_64 root=/dev/mapper/lt1-root ro rd.md=0 rd.dm=0 KEYTABLE=us rd.lvm.lv=lt1/root quiet SYSFONT=latarcyrheb-sun16 rhgb LANG=en_US.UTF-8 rd.luks.uuid=luks-f3556d8f-a720-4af3-90f1-faaca25d66bb
kernel:         3.3.4-3.fc16.x86_64
reason:         WARNING: at fs/dcache.c:2537 prepend_path+0x1c9/0x1e0()
time:           Thu 10 May 2012 11:29:15 AM EDT

backtrace:
:WARNING: at fs/dcache.c:2537 prepend_path+0x1c9/0x1e0()
:Hardware name: MP061                           
:Root dentry has weird name <>  vfsmnt: fs:nfs4
:Modules linked in: nfs fscache auth_rpcgss nfs_acl fuse lockd rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 ip6table_filter xt_state nf_conntrack ip6_tables sunrpc arc4 dell_wmi sparse_keymap btusb bluetooth snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device joydev dell_laptop snd_pcm dcdbas r852 sm_common nand b44 ssb r592 memstick mii nand_ids mtd nand_ecc microcode iwl4965 uinput iwlegacy snd_timer snd soundcore snd_page_alloc i2c_i801 mac80211 iTCO_wdt iTCO_vendor_support cfg80211 rfkill xts gf128mul dm_crypt firewire_ohci firewire_core crc_itu_t sdhci_pci sdhci mmc_core video wmi radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 3211, comm: konsole Not tainted 3.3.4-3.fc16.x86_64 #1
:Call Trace:
: [<ffffffff81057abf>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81057bb6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff8126bcb4>] ? avc_has_perm_flags+0x74/0x90
: [<ffffffff81195f69>] prepend_path+0x1c9/0x1e0
: [<ffffffff81195fdc>] path_with_deleted+0x5c/0xa0
: [<ffffffff8119696b>] d_path+0xab/0xe0
: [<ffffffff811e506b>] proc_pid_readlink+0x9b/0x100
: [<ffffffff8118634d>] sys_readlinkat+0xad/0xb0
: [<ffffffff810d33fc>] ? __audit_syscall_entry+0xcc/0x310
: [<ffffffff8118636b>] sys_readlink+0x1b/0x20
: [<ffffffff815fbee9>] system_call_fastpath+0x16/0x1b

comment:
:May be related to having an NFS4 share open in a terminal session and having Network Manager stop the network connection to that NIC.  Then attempting to close the teminal session as it was locked up.
:
:ONce I renabled the network connection the terminal session was again accessible.  

smolt_data:
:
:
:General
:=================================
:UUID: 18e2b940-ca2c-4ff8-a861-31de48fb4713
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 3994.76
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 CPU         T7200  @ 2.00GHz
:CPU Stepping: 6
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 2000
:System Memory: 3262
:System Swap: 4095
:Vendor: Dell Inc.
:System: MP061 
:Form factor: Portable
:Kernel: 3.3.4-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10144:4136:461) pci, None, HOST/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub
:(32902:10145:4136:461) pci, pcieport, PCI/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port
:(32902:10202:4136:461) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:10180:4136:461) pci, ata_piix, STORAGE, 82801GBM/GHM (ICH7 Family) SATA IDE Controller
:(32902:10169:4136:461) pci, None, PCI/ISA, 82801GBM (ICH7-M) LPC Interface Bridge
:(32902:16937:32902:4384) pci, iwl4965, NETWORK, PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
:(32902:9288:4136:461) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10185:4136:461) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4136:461) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10187:4136:461) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10186:4136:461) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(4480:1426:4136:461) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:(4480:2130:4136:461) pci, r852, BASE, xD-Picture Card Controller
:(4480:2098:4136:461) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:4136:461) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(5348:5900:4136:461) pci, b44, ETHERNET, Inspiron 9400 Laptop
:(32902:10198:4136:461) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 4
:(32902:10192:4136:461) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4136:461) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:4136:461) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(4098:28997:4136:8194) pci, radeon, VIDEO, Radeon Mobility X1400
:(32902:10188:4136:461) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/lt1-root / ext4 4096 4096 2556037 785800 657596 642112 379380 379380
:/dev/sda1 /boot ext4 1024 1024 508745 434526 408926 128016 127748 127748
:/dev/mapper/lt1-var /var ext4 4096 4096 7665590 7334316 6950112 1921360 1916369 1916369
:/dev/mapper/lt1-home /home ext4 4096 4096 2556037 1732422 1604218 642112 632460 632460
:
Comment 1 Dave Jones 2012-05-10 11:50:27 EDT

*** This bug has been marked as a duplicate of bug 766277 ***

Note You need to log in before you can comment on or make changes to this bug.