Bug 820671 - glade strings on manual_subscription screen in firstboot not translated
glade strings on manual_subscription screen in firstboot not translated
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: Translation
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-10 12:12 EDT by Adrian Likins
Modified: 2012-06-20 08:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firstboot no translations (120.28 KB, image/png)
2012-05-14 13:45 EDT, Adrian Likins
no flags Details
strings are now translated in firstboot (156.99 KB, image/png)
2012-05-22 14:51 EDT, John Sefler
no flags Details

  None (edit)
Description Adrian Likins 2012-05-10 12:12:31 EDT
If you register in firstboot, and end up in the manual
subscription screen, the translated strings are not
being shown.

The strings to be appear to be marked for translated, and
translated, but are not being shown.

See attached screenshot
Comment 2 Adrian Likins 2012-05-14 09:43:11 EDT
commit 3357964ecc1aaeb7c59ffbb0fb7d3a04ed1a8c60
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu May 10 13:50:17 2012 -0400

    820671: Fix issues finding translated strings from glade
    
    Use i18n.configure_i18n(with_glade=True) here so glade
    text domains get created correctly.
Comment 4 Adrian Likins 2012-05-14 13:45:55 EDT
Created attachment 584421 [details]
firstboot no translations
Comment 7 John Sefler 2012-05-22 14:51:33 EDT
Created attachment 586131 [details]
strings are now translated in firstboot

Verifying Version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.99.18-1.el6.x86_64

[root@jsefler-r63-server ~]#LANG=ja_JP.UTF-8 firstboot -r
... Forward through firstboot until you get to the "Manual Configuration Required" panel and you will find that it is now translated as shown in the attached screenshot.

moving to VERIFIED.
Comment 9 errata-xmlrpc 2012-06-20 08:57:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.