Bug 820680 - UEFI Grub setup using Kickstart not working
UEFI Grub setup using Kickstart not working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
6.2
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jack Reed
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 12:43 EDT by Christian Becker
Modified: 2013-06-17 01:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 18:43:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The working kickstart file (1.37 KB, text/plain)
2012-05-11 07:12 EDT, Christian Becker
no flags Details

  None (edit)
Description Christian Becker 2012-05-10 12:43:21 EDT
Description of problem:

I have an IBM System X 3690X5 and tried to setup that Machine using Kickstart. I have previously installed a identical Machine using the DVD and a manual Setup procedure, which worked fine.

There is a ESP defined in the Kickstart file, which is correctly created and recognized by UEFI. Unfortunately the ESP only contains EFI/redhat/grub.efi which is not used by UEFI and additionally there is no config file for grub.

I was also unable to find any documentation regarding UEFI and Kickstart - especially how to setup grub.

Version-Release number of selected component (if applicable): RHEL 6.2 DVD


How reproducible:

Install system using provided kickstart file.

Actual results:

a) System is not booting
b) Fallback to grub shell if the grub.efi file is executed manually

Expected results:

System booting correctly.

Additional info:
see attached kickstart config
Comment 2 Chris Lumens 2012-05-10 13:48:42 EDT
Your kickstart file does not appear to be attached.  Also, please attach /tmp/anaconda.log and /tmp/program.log.  These will be in /var/log/anaconda after installation is complete.
Comment 3 Christian Becker 2012-05-11 07:12:25 EDT
Created attachment 583804 [details]
The working kickstart file
Comment 4 Christian Becker 2012-05-11 07:26:31 EDT
Hi,

thanks for your quick reply. I have now some updates.

This is not a bug in the release, but some missing Documentation.

On the Page http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/s1-kickstart2-options.html

At the part or partition definition these are documented supported values: 

--fstype= — Sets the file system type for the partition. Valid values are xfs, ext2, ext3, ext4, swap, vfat, and hfs.

It seems as there is the  fstype 'efi' missing, this is required for anaconda to create the grub config file.

After setting this as fstype instead of vfat, the directory structure remains the same, but fortunately UEFI is able to find /efi/redhat/grub.efi and the grub config is present.

So i think it would be very helpful to include this in the documentation.

For documentation i have previously attached our working kickstart file. This was used to setup the machine with complete EFI support and native UEFI boot. Hopefully this helps some people.
Comment 5 RHEL Product and Program Management 2012-05-15 00:04:31 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Jack Reed 2012-05-21 00:31:12 EDT
(In reply to comment #4)

> --fstype= — Sets the file system type for the partition. Valid values are
> xfs, ext2, ext3, ext4, swap, vfat, and hfs.
> 
> It seems as there is the  fstype 'efi' missing, this is required for
> anaconda to create the grub config file.
> 
> After setting this as fstype instead of vfat, the directory structure
> remains the same, but fortunately UEFI is able to find /efi/redhat/grub.efi
> and the grub config is present.
> 
> So i think it would be very helpful to include this in the documentation.
> 

Thanks for reporting this, Christian. Does this fix address all of the concerns in your original report?

Due to our 6.3 documentation schedule, I will incorporate the fstype 'efi' into the 6.4 Installation Guide.
Comment 7 Christian Becker 2012-05-22 03:11:55 EDT
(In reply to comment #6)
> (In reply to comment #4)
> 
> > --fstype= — Sets the file system type for the partition. Valid values are
> > xfs, ext2, ext3, ext4, swap, vfat, and hfs.
> > 
> > It seems as there is the  fstype 'efi' missing, this is required for
> > anaconda to create the grub config file.
> > 
> > After setting this as fstype instead of vfat, the directory structure
> > remains the same, but fortunately UEFI is able to find /efi/redhat/grub.efi
> > and the grub config is present.
> > 
> > So i think it would be very helpful to include this in the documentation.
> > 
> 
> Thanks for reporting this, Christian. Does this fix address all of the
> concerns in your original report?
> 
> Due to our 6.3 documentation schedule, I will incorporate the fstype 'efi'
> into the 6.4 Installation Guide.

Hi Jack,

thanks for your reply.

This was the only change i made with parameters not contained in the documentation.

The other required change was the bootloader statement:

bootloader --location=partition --driveorder=sda

I don´t know if this implies any changes to the bootloader install process, but i guess it should be also documented to use --location=partition in conjunction with UEFI.
Comment 8 Jack Reed 2012-07-26 21:16:16 EDT
Great, thanks Christian. For the 6.4 edition of the guide, I'll edit the description of the location argument for the bootloader kickstart option to state that specifying the partition is necessary for UEFI systems.
Comment 12 Jack Reed 2013-02-25 18:43:31 EST
This bug has been verified and implemented for 6.4, so I am changing the status to CLOSED CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.