Bug 820721 - F17 alpha PPC64: samba service failed to start
F17 alpha PPC64: samba service failed to start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: samba4 (Show other bugs)
17
ppc64 All
unspecified Severity urgent
: ---
: ---
Assigned To: Andreas Schneider
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 15:00 EDT by IBM Bug Proxy
Modified: 2012-07-23 16:21 EDT (History)
7 users (show)

See Also:
Fixed In Version: samba4-4.0.0-49alpha18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 16:21:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
var-log-samba_log.smbd (3.42 KB, text/plain)
2012-05-10 15:00 EDT, IBM Bug Proxy
no flags Details
var-log-samba_log.nmbd (1.12 KB, text/plain)
2012-05-10 15:00 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 81497 None None None Never

  None (edit)
Description IBM Bug Proxy 2012-05-10 15:00:27 EDT
While trying start samba services on Fedora 17 Alpha PPC64 (3.3.4-1.fc17.ppc64) on P7 server, it failed to start by following error.

[root@elm17f130 ~]# systemctl enable smb.service
ln -s '/usr/lib/systemd/system/smb.service' '/etc/systemd/system/multi-user.target.wants/smb.service'

[root@elm17f130 ~]# systemctl enable nmb.service
ln -s '/usr/lib/systemd/system/nmb.service' '/etc/systemd/system/multi-user.target.wants/nmb.service'

[root@elm17f130 ~]# systemctl start smb.service nmb.service

[root@elm17f130 ~]# systemctl status smb.service nmb.service
smb.service - Samba SMB Daemon
	  Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled)
	  Active: failed (Result: exit-code) since Thu, 10 May 2012 15:00:01 -0400; 2s ago
	 Process: 28256 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)
	Main PID: 28259 (code=exited, status=255)
	  CGroup: name=systemd:/system/smb.service


nmb.service - Samba NMB Daemon
	  Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled)
	  Active: failed (Result: exit-code) since Thu, 10 May 2012 15:00:01 -0400; 2s ago
	 Process: 28257 ExecStart=/usr/sbin/nmbd $NMBDOPTIONS (code=exited, status=0/SUCCESS)
	Main PID: 28258 (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/nmb.service


--- logs from /var/log/messages ---
May 10 15:00:01 elm17f130 smbd[28256]: [2012/05/10 15:00:01.845442,  0] ../source3/smbd/server.c:1179(main)
May 10 15:00:01 elm17f130 smbd[28256]:   standard input is not a socket, assuming -D option
May 10 15:00:01 elm17f130 systemd[1]: nmb.service: main process exited, code=exited, status=1
May 10 15:00:01 elm17f130 systemd[1]: Unit nmb.service entered failed state.
May 10 15:00:01 elm17f130 smbd[28259]: [2012/05/10 15:00:01.897810,  0] ../lib/util/util.c:158(directory_create_or_exist)
May 10 15:00:01 elm17f130 smbd[28259]:   error creating directory /run/samba/ncalrpc: No such file or directory
May 10 15:00:01 elm17f130 smbd[28259]: [2012/05/10 15:00:01.898079,  0] ../source3/smbd/server.c:1336(main)
May 10 15:00:01 elm17f130 smbd[28259]:   Failed to create pipe directory /run/samba/ncalrpc - No such file or directory
May 10 15:00:01 elm17f130 systemd[1]: smb.service: main process exited, code=exited, status=255
May 10 15:00:01 elm17f130 systemd[1]: Unit smb.service entered failed state.


--- uname -a ---
[root@elm17f130 ~]# uname -a
Linux elm17f130.x.x.x 3.3.4-1.fc17.ppc64 #1 SMP Tue May 1 12:48:10 MST 2012 ppc64 ppc64 ppc64 GNU/Linux

--- Samba packages installed ---
[root@elm17f130 ~]# rpm -qa | grep -i samba
samba4-dc-4.0.0-47alpha18.fc17.ppc64
samba4-winbind-clients-4.0.0-47alpha18.fc17.ppc64
samba4-swat-4.0.0-47alpha18.fc17.ppc64
samba4-libs-4.0.0-47alpha18.fc17.ppc64
samba4-client-4.0.0-47alpha18.fc17.ppc64
samba4-test-4.0.0-47alpha18.fc17.ppc64
samba4-winbind-krb5-locator-4.0.0-47alpha18.fc17.ppc64
samba4-dc-libs-4.0.0-47alpha18.fc17.ppc64
samba4-winbind-4.0.0-47alpha18.fc17.ppc64
samba4-devel-4.0.0-47alpha18.fc17.ppc64
samba4-common-4.0.0-47alpha18.fc17.ppc64
samba4-4.0.0-47alpha18.fc17.ppc64
samba4-python-4.0.0-47alpha18.fc17.ppc64
samba4-pidl-4.0.0-47alpha18.fc17.ppc64

[root@elm17f130 ~]# rpm -qa | grep -i cifs
cifs-utils-5.4-1.fc17.ppc64

[root@elm17f130 ~]# systemctl list-units --all |grep nmb
nmb.service               loaded failed   failed        Samba NMB Daemon

[root@elm17f130 ~]# systemctl list-units --all |grep smb
smb.service               loaded failed   failed        Samba SMB Daemon

[root@elm17f130 ~]# ls -ld /run
drwxr-xr-x 19 root root 720 May 10 15:01 /run

[root@elm17f130 ~]# ls -ld /run/samba
ls: cannot access /run/samba: No such file or directory

[root@elm17f130 ~]# ls -l /run/samba
ls: cannot access /run/samba: No such file or directory

[root@elm17f130 ~]# rpm -qa | grep -i selinux
selinux-policy-3.10.0-110.fc17.noarch
selinux-policy-targeted-3.10.0-110.fc17.noarch
libselinux-python-2.1.10-3.fc17.ppc64
libselinux-2.1.10-3.fc17.ppc64
libselinux-utils-2.1.10-3.fc17.ppc64

[root@elm17f130 ~]# getenforce 
Disabled

[root@elm17f130 ~]# cat /run/smbd.pid 
28259
[root@elm17f130 ~]# cat /run/nmbd.pid 
28258
[root@elm17f130 ~]# ls -l /run/nmbd.pid 
-rw-r--r-- 1 root root 6 May 10 15:00 /run/nmbd.pid
[root@elm17f130 ~]# ls -l /run/smbd.pid 
-rw-r--r-- 1 root root 6 May 10 15:00 /run/smbd.pid

Also attached files named as smb.conf , var-log-samba_log.nmbd &  var-log-samba_log.smbd got collected from /var/log/samba/log.%m.
Comment 1 IBM Bug Proxy 2012-05-10 15:00:41 EDT
Created attachment 583654 [details]
var-log-samba_log.smbd
Comment 2 IBM Bug Proxy 2012-05-10 15:00:54 EDT
Created attachment 583655 [details]
var-log-samba_log.nmbd
Comment 3 Andreas Schneider 2012-05-11 05:36:04 EDT
Do you have the following file:

/etc/tmpfiles.d/samba.conf

This should make sure that /var/run/samba (/run/samba) is created by systemd on boot.
Comment 4 IBM Bug Proxy 2012-05-11 08:00:57 EDT
------- Comment From maknayak@in.ibm.com 2012-05-11 11:53 EDT-------
(In reply to comment #9)
> Do you have the following file:
>
> /etc/tmpfiles.d/samba.conf
>
> This should make sure that /var/run/samba (/run/samba) is created by systemd
> on boot.

Yes Server has the same file and it has following content in it:

[root@elm17f130 ~]# cat /etc/tmpfiles.d/samba.conf
d /var/run/samba  755 root root

[root@elm17f130 ~]# ls -l /etc/tmpfiles.d/samba.conf
-rw-r--r-- 1 root root 32 May  8 19:57 /etc/tmpfiles.d/samba.conf

Thanks...
Manas
Comment 5 IBM Bug Proxy 2012-05-11 09:00:35 EDT
------- Comment From baude@us.ibm.com 2012-05-11 12:55 EDT-------
@asn, that's an interesting point re: 'on boot' .  It appears that /run/samba IS created on boot, but not if you just yum install samba4.  Is there a way to account for this without a reboot?
Comment 6 Alexander Bokovoy 2012-05-11 10:35:30 EDT
To confirm, the issue you are seeing is that someone needs to trigger running /etc/tmpfiles.d/samba.conf after the samba4 package is installed or otherwise samba will not work properly if started BEFORE the reboot.

I think we need to add 

/usr/bin/systemd-tmpfiles --create /etc/tmpfiles.d/samba.conf

to post-install script to ensure the content of the samba.conf is correctly processed.

Could you please confirm that running the line above manually allows you to start samba afterwards without reboot?
Comment 7 IBM Bug Proxy 2012-05-11 11:20:55 EDT
------- Comment From baude@us.ibm.com 2012-05-11 15:13 EDT-------
Yeah that does the trick
Comment 8 IBM Bug Proxy 2012-05-28 08:50:27 EDT
------- Comment From maknayak@in.ibm.com 2012-05-28 12:42 EDT-------
(In reply to comment #15)
> Hi Manas,
>    Is it possible to verify whether the changes in the samba package are
> present in beta?
>
> Regards,
> Seenu.

Hi Seenu,
I installed samba4 packages on f17 beta ppc64 , and verified by starting both the services smb & nmb .It could start successfully.

[root@miz11 ~]# systemctl start smb.service nmb.service
[root@miz11 ~]# systemctl status smb.service nmb.service
Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled)
Active: active (running) since Mon, 28 May 2012 12:39:12 -0400; 6s ago
Process: 1070 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)
Main PID: 1072 (smbd)
? 1072 /usr/sbin/smbd
? 1073 /usr/sbin/smbd

Loaded: loaded (/usr/lib/systemd/system/nmb.service; disabled)
Active: active (running) since Mon, 28 May 2012 12:39:13 -0400; 6s ago
Process: 1071 ExecStart=/usr/sbin/nmbd $NMBDOPTIONS (code=exited, status=0/SUCCESS)
Main PID: 1075 (nmbd)
? 1075 /usr/sbin/nmbd

[root@miz11 ~]# rpm -qa | grep -i samba
[root@miz11 ~]# uname -a
Linux miz11.austin.ibm.com 3.3.4-4.fc17.ppc64 #1 SMP Tue May 8 17:19:04 MST 2012 ppc64 ppc64 ppc64 GNU/Linux

looks like Beta has fix for this issue?

Thanks...
Manas
Comment 9 IBM Bug Proxy 2012-05-29 12:51:16 EDT
------- Comment From clnperez@us.ibm.com 2012-05-29 16:41 EDT-------
Fedora folks - This was not reproducible on Beta so we have closed the bug on our side.

Thanks.
Comment 10 Fedora Update System 2012-06-04 05:25:27 EDT
samba4-4.0.0-51alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/samba4-4.0.0-51alpha18.fc17
Comment 11 Fedora Update System 2012-06-06 12:42:16 EDT
samba4-4.0.0-52alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-8842/samba4-4.0.0-52alpha18.fc17
Comment 12 Fedora Update System 2012-06-12 14:48:26 EDT
samba4-4.0.0-53alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/samba4-4.0.0-53alpha18.fc17
Comment 13 Fedora Update System 2012-06-14 20:27:32 EDT
Package samba4-4.0.0-53alpha18.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing samba4-4.0.0-53alpha18.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9393/samba4-4.0.0-53alpha18.fc17
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-06-18 08:26:35 EDT
samba4-4.0.0-54alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/samba4-4.0.0-54alpha18.fc17
Comment 15 Fedora Update System 2012-06-21 16:02:39 EDT
samba4-4.0.0-55alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/samba4-4.0.0-55alpha18.fc17
Comment 16 Brent Baude 2012-06-21 17:52:43 EDT
ppc64 builds should eventually land here -> http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=593100
Comment 17 Fedora Update System 2012-06-22 11:21:46 EDT
samba4-4.0.0-56alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/samba4-4.0.0-56alpha18.fc17
Comment 18 Fedora Update System 2012-07-12 12:11:56 EDT
samba4-4.0.0-58alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/samba4-4.0.0-58alpha18.fc17
Comment 19 Fedora Update System 2012-07-23 16:21:57 EDT
samba4-4.0.0-58alpha18.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.