Bug 82073 - screen improperly blanks when using serial mouse in X
screen improperly blanks when using serial mouse in X
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-16 22:24 EST by Joseph
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 15:24:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config (3.37 KB, text/plain)
2003-03-02 01:53 EST, Joseph
no flags Details
XFree86 log (8.32 KB, text/plain)
2003-03-02 01:58 EST, Joseph
no flags Details

  None (edit)
Description Joseph 2003-01-16 22:24:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3b) Gecko/20021216

Description of problem:
While using a serial mouse in X, the screen will eventually blank while the
mouse is in use.  Using the nubule on the keyboard (AKA PS2 pointing device),
the screen comes back.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install a serial mouse
2.Add it as a core pointer-sending device
3.Start X
4.Work with the serial mouse only for a while and the screen goes blank
5.Move the pointer with the PS2 pointer and the screen comes back
    

Actual Results:  Screen goes dark despite serial mouse usage

Expected Results:  Shouldn't matter what pointer is used; core pointer events
should prevent screen blanking.

Additional info:

Relevant portions of XF86Config can be provided if you want it.


Left severity at Normal instead of Low although a simple workaround (move the
nubule-mouse) exists because it's annoying my wife, whom I'm trying to get to
switch to Linux!  :)
Comment 1 Mike A. Harris 2003-01-18 04:43:49 EST
Attach your complete config file and X server log file using the link
below.  Be sure to set the mimetype to text/plain
Comment 2 Mike A. Harris 2003-01-24 09:04:46 EST
ping
Comment 3 Joseph 2003-01-24 16:36:22 EST
Pong.

Waiting to get access to my wife's computer so that I can snag the info.  I
shoulda just left it in the bug report.  :/

Will report back tonight with the info.
Comment 4 Mike Chambers 2003-01-29 19:35:25 EST
Joeseph,

We still need those files to better look at this bug.
Comment 5 Joseph 2003-03-02 01:53:01 EST
Created attachment 90436 [details]
XF86Config

The XF86Config file in question.
Comment 6 Joseph 2003-03-02 01:58:16 EST
Created attachment 90437 [details]
XFree86 log

Log file from the X server.  Is huge (>3MB!) so is bzip2'ed.
Comment 7 Joseph 2003-03-02 02:00:25 EST
Sorry for the high lag.  Things have been hectic here.

Hope these help.  I'll try to be more responsive if you need more info.
Comment 8 Mike A. Harris 2004-09-24 14:58:54 EDT
Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.