Bug 820747 - libxcb-devel x86_64 has a i686 dependency, causes an error when installing
libxcb-devel x86_64 has a i686 dependency, causes an error when installing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 16:57 EDT by Matthew Yates
Modified: 2014-01-21 18:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 13:10:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Yates 2012-05-10 16:57:07 EDT
Description of problem:

When trying to install the package libxcb-devel-1.8-2.fc17.x86_64, an i868 version of the package libxcd is called as a dependency. Which causes:
Error: Protected multilib versions: libxcb-1.8-2.fc17.i686 != libxcb-1.8.1-1.fc17.x86_64
which prevents installing the X11 devel packages. 

Version-Release number of selected component (if applicable):

How reproducible:

Every time on Fedora 17 beta

Steps to Reproduce:

yum install libxcb-devel-1.8-2.fc17.x86_64
  
Actual results:

--> Running transaction check
---> Package libxcb-devel.x86_64 0:1.8-2.fc17 will be installed
--> Processing Dependency: libxcb = 1.8-2.fc17 for package: libxcb-devel-1.8-2.fc17.x86_64
--> Running transaction check
---> Package libxcb.i686 0:1.8-2.fc17 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libxcb-1.8-2.fc17.i686
--> Processing Dependency: libXau.so.6 for package: libxcb-1.8-2.fc17.i686
--> Running transaction check
---> Package glibc.i686 0:2.15-35.fc17 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.15-35.fc17.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.15-35.fc17.i686
---> Package libXau.i686 0:1.0.6-3.fc17 will be installed
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.13.4-2.fc17 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: libxcb-1.8-2.fc17.i686 != libxcb-1.8.1-1.fc17.x86_64
Comment 1 James Antill 2012-05-11 13:10:56 EDT
 The problem is that the isntalled version "libxcb-1.8.1-1.fc17" is newer than the available version "libxcb-1.8-2.fc17" (1.8.1 > 1.8). Yum won't do automatic downgrades, so it tries to solve the problem by installing the .i686 version ... but that hits multilib conflicts.

 Use downgrade/distro-sync, and all should be fixed.

Note You need to log in before you can comment on or make changes to this bug.