This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 820748 - system-config-kickstart is broken
system-config-kickstart is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
RejectedNTH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 17:05 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-06-27 17:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: system-config-kickstart-2.8.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-10 10:31:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
matthiasworsch@googlemail.com (12.40 KB, application/octet-stream)
2012-05-21 09:51 EDT, matthiasworsch
no flags Details
Comment (262.07 KB, text/plain)
2012-05-10 17:05 EDT, Ankur Sinha (FranciscoD)
no flags Details

  None (edit)
Description Ankur Sinha (FranciscoD) 2012-05-10 17:05:24 EDT
Created attachment 915454 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Chris Lumens 2012-05-14 11:26:41 EDT
Do you have anything installed that provides /usr/lib*/python*/site-packages/firewall.py?
Comment 2 Ankur Sinha (FranciscoD) 2012-05-14 12:41:57 EDT
Hello,

Apparently not. The repos don't seem to have any package either:

[ankur@ankur ~]$ locate "firewall.py"
/usr/lib/python2.7/site-packages/pykickstart/commands/firewall.py
/usr/lib/python2.7/site-packages/pykickstart/commands/firewall.pyc
/usr/lib/python2.7/site-packages/pykickstart/commands/firewall.pyo
/usr/lib64/python2.7/site-packages/pyanaconda/firewall.py
/usr/lib64/python2.7/site-packages/pyanaconda/firewall.pyc
/usr/lib64/python2.7/site-packages/pyanaconda/firewall.pyo
/usr/share/system-config-kickstart/firewall.py
/usr/share/system-config-kickstart/firewall.pyc
/usr/share/system-config-kickstart/firewall.pyo
[ankur@ankur ~]$


[root@ankur ~]# yum whatprovides /usr/lib*/python*/site-packages/firewall.py
Loaded plugins: changelog, fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror-fpt-telecom.fpt.net
 * rpmfusion-free: ftp.upjs.sk
 * rpmfusion-free-updates: mirror.cse.iitk.ac.in
 * rpmfusion-free-updates-testing: ftp.upjs.sk
 * rpmfusion-nonfree: ftp.upjs.sk
 * rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree-updates-testing: ftp.upjs.sk
 * updates: mirror.cse.iitk.ac.in
No Matches found


[root@ankur ~]# yum whatprovides */site-packages/firewall.py
Loaded plugins: changelog, fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror-fpt-telecom.fpt.net
 * rpmfusion-free: ftp.upjs.sk
 * rpmfusion-free-updates: mirror.cse.iitk.ac.in
 * rpmfusion-free-updates-testing: ftp.upjs.sk
 * rpmfusion-nonfree: ftp.upjs.sk
 * rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree-updates-testing: ftp.upjs.sk
 * updates: mirror.cse.iitk.ac.in
No Matches found


[root@ankur ~]# yum whatprovides */firewall.py
Loaded plugins: changelog, fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror-fpt-telecom.fpt.net
 * rpmfusion-free: ftp.upjs.sk
 * rpmfusion-free-updates: mirror.cse.iitk.ac.in
 * rpmfusion-free-updates-testing: ftp.upjs.sk
 * rpmfusion-nonfree: ftp.upjs.sk
 * rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree-updates-testing: ftp.upjs.sk
 * updates: mirror.cse.iitk.ac.in
anaconda-17.26-1.fc17.x86_64 : Graphical system installer
Repo        : fedora
Matched from:
Filename    : /usr/lib64/python2.7/site-packages/pyanaconda/firewall.py



openstack-quantum-ryu-2012.1-1.fc17.noarch : Quantum ryu plugin
Repo        : fedora
Matched from:
Filename    : /usr/lib/python2.7/site-packages/quantum/plugins/ryu/nova/firewall.py



1:prelude-correlator-1.0.0-4.fc17.noarch : Real time correlator of events received by Prelude Manager
Repo        : fedora
Matched from:
Filename    : /usr/lib/python2.7/site-packages/PreludeCorrelator/plugins/firewall.py



pykickstart-1.99.7-1.fc17.noarch : A python library for manipulating kickstart files
Repo        : fedora
Matched from:
Filename    : /usr/lib/python2.7/site-packages/pykickstart/commands/firewall.py



python-nova-2012.1-2.fc17.noarch : Nova Python libraries
Repo        : fedora
Matched from:
Filename    : /usr/lib/python2.7/site-packages/nova/virt/firewall.py
Filename    : /usr/lib/python2.7/site-packages/nova/virt/xenapi/firewall.py
Filename    : /usr/lib/python2.7/site-packages/nova/virt/libvirt/firewall.py



system-config-kickstart-2.8.8-2.fc17.noarch : A graphical interface for making kickstart files
Repo        : fedora
Matched from:
Filename    : /usr/share/system-config-kickstart/firewall.py



system-config-printer-libs-1.3.9-1.fc17.x86_64 : Libraries and shared code for printer administration tool
Repo        : fedora
Matched from:
Filename    : /usr/share/system-config-printer/firewall.py



anaconda-17.26-1.fc17.x86_64 : Graphical system installer
Repo        : @fedora
Matched from:
Filename    : /usr/lib64/python2.7/site-packages/pyanaconda/firewall.py



pykickstart-1.99.7-1.fc17.noarch : A python library for manipulating kickstart files
Repo        : @fedora
Matched from:
Filename    : /usr/lib/python2.7/site-packages/pykickstart/commands/firewall.py



system-config-kickstart-2.8.8-2.fc17.noarch : A graphical interface for making kickstart files
Repo        : @fedora
Matched from:
Filename    : /usr/share/system-config-kickstart/firewall.py



[root@ankur ~]#

Thanks,
Ankur
Comment 3 Chris Lumens 2012-05-14 14:10:24 EDT
Looks like it's firewalld providing /usr/lib/python2.7/site-packages/firewall.  Great.
Comment 4 Ankur Sinha (FranciscoD) 2012-05-14 14:34:05 EDT
Really?

Since I installed F17 from beta, I have firewalld running:

[root@ankur ~]# rpm -q firewalld
firewalld-0.2.5-1.fc17.noarch
[root@ankur ~]#

So, firewalld should not be providing the file, since the locate command (in the earlier comment) didn't find it.

[ankur@ankur ~]$ rpm -ql firewalld | egrep "firewall.py"

returns nothing :/

Thanks,
Ankur
Comment 5 Chris Lumens 2012-05-14 16:00:26 EDT
system-config-kickstart-2.8.10 out of rawhide will fix this, but it'd be really nice to have it fixed in the release as well.  Of course, I could also just do an update.
Comment 6 Adam Williamson 2012-05-14 20:40:37 EDT
Unless I'm missing something here, an update should address this perfectly well; there's no use of s-c-kickstart during installation and it's not in the live images. So there's no real point to pulling it through the freeze. (It's not even included in a default DVD install, though it's on the DVD). Definitely -1 blocker, probably -1 NTH.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Ankur Sinha (FranciscoD) 2012-05-15 08:27:31 EDT
(In reply to comment #6)
> Unless I'm missing something here, an update should address this perfectly
> well; there's no use of s-c-kickstart during installation and it's not in the
> live images. So there's no real point to pulling it through the freeze. (It's
> not even included in a default DVD install, though it's on the DVD). Definitely
> -1 blocker, probably -1 NTH.
> 
> 

Blocker -1 (definitely, an update later would fix this)
NTH +1

Writing kickstarts using a text editor is a tad bit intimidating to new people IMO. I ended up learning the details because s-c-k wasn't working ;)
Comment 8 Kamil Páral 2012-05-15 08:34:32 EDT
Ankur, please be so kind and next time place just an excerpt of the error message into bug description and put the whole log as attachment. It will make the bug much more readable, thanks.

-1 blocker, not part of default desktop

Ankur, what is the reason to have this NTH? Currently I don't see any.
Comment 9 Ankur Sinha (FranciscoD) 2012-05-15 10:53:22 EDT
(In reply to comment #8)
> Ankur, please be so kind and next time place just an excerpt of the error
> message into bug description and put the whole log as attachment. It will make
> the bug much more readable, thanks.
> 
> -1 blocker, not part of default desktop
> 
> Ankur, what is the reason to have this NTH? Currently I don't see any.


Well, basically it would be good to have this working for folks who want to be able to use kickstart files to set up multiple systems at a go. Like I've said, you can write kickstarts in a text editor, but s-c-k would be preferred. It is simpler.
Comment 10 Chris Lumens 2012-05-15 11:28:58 EDT
I'll just do an update.
Comment 11 Adam Williamson 2012-05-15 11:31:05 EDT
seems to be general agreement that there's no need for this to be a blocker, at least; downgrading to proposed NTH, can be dropped as NTH with one more vote.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Kamil Páral 2012-05-18 09:27:16 EDT
Ankur, I think you don't understand what NTH process is about. We don't need to have this fixed on the installation media, it's enough to have this fixed using standard F17 updates repo. -1 NTH.
Comment 13 Tim Flink 2012-05-18 17:27:46 EDT
Discussed in the 2012-05-18 blocker bug review meeting. Rejected as NTH for Fedora 17 final because this package is not on the DVDs and therefore could be fixed with an update.
Comment 14 matthiasworsch 2012-05-21 09:51:57 EDT
Created attachment 585819 [details]
matthiasworsch@googlemail.com
Comment 15 Ankur Sinha (FranciscoD) 2012-05-21 11:01:15 EDT
(In reply to comment #12)
> Ankur, I think you don't understand what NTH process is about. We don't need
> to have this fixed on the installation media, it's enough to have this fixed
> using standard F17 updates repo. -1 NTH.

Aye, I think I understand. I'm happy as long as it gets fixed :)

Thanks,
Ankur
Comment 16 Ankur Sinha (FranciscoD) 2012-05-21 11:04:51 EDT
(In reply to comment #14)
> Created attachment 585819 [details]
> matthiasworsch@googlemail.com

Er.. what is this attachment about please matthias? Looks like something to do with google chrome. Not sure how it's relevant to this bug on s-c-k.

Ankur

Note You need to log in before you can comment on or make changes to this bug.