Bug 820751 - F17 gcc miscompiles lilypond
F17 gcc miscompiles lilypond
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F17-accepted/F17FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-05-10 17:13 EDT by Jakub Jelinek
Modified: 2012-05-18 19:06 EDT (History)
6 users (show)

See Also:
Fixed In Version: gcc-4.7.0-5.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 19:06:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 53239 None None None Never

  None (edit)
Description Jakub Jelinek 2012-05-10 17:13:23 EDT
See http://gcc.gnu.org/PR53239
It would be nice not to have this wrong-code bug in F17 GA, internal compiler errors etc. are less severe than silent miscompilations.

https://admin.fedoraproject.org/updates/FEDORA-2012-7449/gcc-4.7.0-5.fc17,gcc-python-plugin-0.9-4.fc17
fixes this bug.
Comment 1 Jakub Jelinek 2012-05-10 17:15:22 EDT
Additionally, gcc-python-plugin will not install in current F17 tree, as it hasn't been rebuilt against any recent gcc.
Comment 2 Adam Williamson 2012-05-10 18:38:49 EDT
I think this is meant to be proposed as NTH, not blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Dennis Gilmore 2012-05-11 22:20:03 EDT
+1 NTH, I can see people doinga f17 install, and never updating it then wondering whats wrong with gcc.
Comment 4 Bruno Wolff III 2012-05-13 09:22:40 EDT
-1 NTH this can be fixed with an update and it's impact on live images is going to be pretty small. (As far as I can tell gcc-python-plugin shouldn't end up on the install or live images; if it does and there is a problem installing that version, then I think this would be a blocker.)
Comment 5 Tim Flink 2012-05-14 13:51:16 EDT
-1 NTH as this could be fixed with an update and AFAIK, isn't on the DVD so users would have to hit the network to install this anyways.
Comment 6 Adam Williamson 2012-05-14 19:13:39 EDT
Tim: gcc is on the DVD.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Tim Flink 2012-05-14 19:44:38 EDT
(In reply to comment #6)
> Tim: gcc is on the DVD.

Yes, I know that but I thought this was an issue with gcc-python-plugin which, as far as I know, isn't on the DVD.

If this is indeed an issue with the base gcc and not just gcc-python[23]-plugin, then I am less -1 NTH on this

I don't pretend to completely understand the upstream bug but what are the possible side effects?
Comment 8 Jakub Jelinek 2012-05-15 01:37:46 EDT
There is a gcc-c++ bug (well, several, this one is just most severe), where e.g.
(for complete testcase look up the upstream bug):

M
test (M *x)
{
  M n (R (0, 0));

  for (int i = 0; i < 2; i++)
  {
    M p = x[i];
    n = min (n, p);
  }
 	
  return n;
}
from the testcase is miscompiled, can affect most of the C++ code (because named return value optimization is very common in C++).  Here because M is not a POD type, the value is returned to memory pointed by a hidden argument, and NRV optimizes the code to have the variable n constructed in that memory.  What the bug is about is that the value range propagation pass computed badly the expected range of the hidden argument (assumed it is uninitialized), and if you are unlucky enough like lilypond was, it can result in silent miscompilation of it.
The gcc bug only affects gcc-* packages.

The second issue is just that gcc-python-plugin, which depends on gcc exact NVR, hasn't been rebuilt for quite a while, so it has broken dependencies.
Comment 9 Tim Flink 2012-05-18 17:22:05 EDT
Discussed in the 2012-05-18 blocker bug review meeting. Accepted as NTH for Fedora 17 final because this could cause problems with c++ compilation with the gcc packages released on DVDs.
Comment 10 Adam Williamson 2012-05-18 19:06:34 EDT
The update is pushed stable, so closing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.