Bug 820767 - lrelease-qt4 tries to run qmake not qmake-qt4
lrelease-qt4 tries to run qmake not qmake-qt4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 19:14 EDT by Samuel Sieb
Modified: 2012-06-05 19:08 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 19:01:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuel Sieb 2012-05-10 19:14:56 EDT
In the qt-devel-4.8.1-5.fc16 package, lrelease is named lrelease-qt4 and qmake is named qmake-qt4.  However, lrelease-qt4 is trying to call qmake instead of qmake-qt4, so it doesn't work.
Comment 1 Jaroslav Reznik 2012-05-21 06:33:45 EDT
Could you be please more specific? I don't see any problem with lrelease-qt4 and I don't see qmake call from it. Could you prepare steps to reproduce? Thanks.
Comment 2 Rex Dieter 2012-05-21 09:09:55 EDT
I fixed this in rawhide a little while ago, the fix will be rolled into the next qt update we make (within a week or 2 or so).

* Fri May 11 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-11
- lrelease-qt4 tries to run qmake not qmake-qt4 (#820767)

See,
http://pkgs.fedoraproject.org/gitweb/?p=qt.git;a=commit;h=d8c792b4fc3c8f9086892e98d5563bfd659ab5db

But Jaraslov has a point, having a reproducible test case would be nice (esp to be able to confirm the reported issue is fixed.
Comment 3 Samuel Sieb 2012-05-23 00:39:21 EDT
I apologize for the lack of info.  I have never used it before, I was just trying to build a program that I found.  I should have also mentioned that I used "strings" on the lrelease-qt4 binary and saw the "qmake" string, but not "qmake-qt4".
Comment 4 Rex Dieter 2012-05-23 11:42:57 EDT
I think what Jaraslov wants... and me too, is a concrete example of something that doesn't work, like:

1. here's an example file
2. try to run lrelease-qt4 on it
3. enjoy smoke and fire
Comment 5 Ngo Than 2012-05-24 12:08:22 EDT
(In reply to comment #2)
> I fixed this in rawhide a little while ago, the fix will be rolled into the
> next qt update we make (within a week or 2 or so).
> 
> * Fri May 11 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-11
> - lrelease-qt4 tries to run qmake not qmake-qt4 (#820767)
> 
> See,
> http://pkgs.fedoraproject.org/gitweb/?p=qt.git;a=commit;
> h=d8c792b4fc3c8f9086892e98d5563bfd659ab5db
> 

the fix looks fine to me and should fix this issue.
Comment 6 Fedora Update System 2012-05-24 12:09:43 EDT
qt-4.8.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qt-4.8.2-1.fc17
Comment 7 Fedora Update System 2012-05-24 12:11:08 EDT
qt-4.8.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qt-4.8.2-1.fc16
Comment 8 Samuel Sieb 2012-05-25 14:50:43 EDT
I'm still getting the following error, but it's working, so perhaps it doesn't matter:

$ lrelease-qt4 stopmotion.pro
sh: /usr/bin/qmake: No such file or directory
Could not find qmake configuration directoryCould not find qmake configuration fileUsing OS scope before setting MAKEFILE_GENERATOR

I can't see anywhere in the project that would be causing this and I still see the "/qmake" string in the lrelease-qt4 binary.

Maybe it's the following line in tools/configure/configure.pro:

DEFINES  += QT_BOOTSTRAPPED
Comment 9 Kevin Kofler 2012-05-25 18:11:35 EDT
Looks like the patch is wrong or incomplete. The
> #ifdef QT_BOOTSTRAPPED
>             option.initProperties(binDir + QLatin1String("/qmake"));
branch of the code is a problem (or even the problem), we need to patch it too.
Comment 10 Fedora Update System 2012-05-26 03:30:24 EDT
Package qt-4.8.2-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.8.2-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8397/qt-4.8.2-1.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-05-26 21:59:34 EDT
Package qt-4.8.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.8.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8483/qt-4.8.2-1.fc16
then log in and leave karma (feedback).
Comment 12 Ngo Than 2012-05-29 06:07:18 EDT
the patch is uncomplete, i will take a look at this
Comment 13 Ngo Than 2012-05-29 10:14:38 EDT
(In reply to comment #8)
> I'm still getting the following error, but it's working, so perhaps it
> doesn't matter:
> 
> $ lrelease-qt4 stopmotion.pro
> sh: /usr/bin/qmake: No such file or directory
> Could not find qmake configuration directoryCould not find qmake
> configuration fileUsing OS scope before setting MAKEFILE_GENERATOR
> 
> I can't see anywhere in the project that would be causing this and I still
> see the "/qmake" string in the lrelease-qt4 binary.
> 
> Maybe it's the following line in tools/configure/configure.pro:
> 
> DEFINES  += QT_BOOTSTRAPPED

could you please download and install new qt packes from
http://koji.fedoraproject.org/koji/taskinfo?taskID=4111637

does the new package fix your problem?

thanks
Comment 14 Samuel Sieb 2012-05-29 16:00:04 EDT
Yes, with that build there are no more errors or warnings.
Comment 15 Ngo Than 2012-05-30 06:11:04 EDT
(In reply to comment #14)
> Yes, with that build there are no more errors or warnings.

thanks, new qt package is added
Comment 16 Fedora Update System 2012-05-30 20:56:08 EDT
Package qt-4.8.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.8.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8483/qt-4.8.2-2.fc16
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2012-06-05 19:01:04 EDT
qt-4.8.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-06-05 19:08:22 EDT
qt-4.8.2-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.