Bug 820770 - A few of beaker's dependencies do not currently exist on ppc64
A few of beaker's dependencies do not currently exist on ppc64
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
ppc64 Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: beaker-dev-list
Misc
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 19:29 EDT by Nish Aravamudan
Modified: 2013-07-29 21:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 21:03:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nish Aravamudan 2012-05-10 19:29:00 EDT
python-gevent
cluster
fence-agents

In turn, these packages depend on other x86/x86_64 specific packages (the src.rpms thereof restrict the architecture).
Comment 1 Nick Coghlan 2012-10-17 00:36:32 EDT
Bulk reassignment of issues as Bill has moved to another team.
Comment 2 Dan Callaghan 2012-10-24 23:49:48 EDT
Unfortunately gevent relies on greenlet, which is x86-only.
Comment 3 Nish Aravamudan 2012-10-25 02:58:50 EDT
Hrm? greenlet exists on ppc64, I've been working on fixing it to actually work in Fedora :)
Comment 4 Dan Callaghan 2012-10-26 00:48:45 EDT
Oh cool, I didn't realise that.
Comment 5 Nick Coghlan 2012-11-07 01:20:22 EST
Reverting to NEW to more accurately reflect current status.
Comment 7 Dan Callaghan 2013-07-29 21:03:08 EDT
I've added ppc64 packages to our yum repos at http://beaker-project.org/yum/server/ so beaker-server and beaker-lab-controller can be installed on ppc64 now.

Unfortunately we can't run our tests on ppc64 since they require Selenium and Java which are not available.

Note You need to log in before you can comment on or make changes to this bug.