Bug 820775 - autocomplete widgets on the system page refer to /bkr/bkr/tg_widgets/turbogears.widgets/spinnerstopped.png
autocomplete widgets on the system page refer to /bkr/bkr/tg_widgets/turbogea...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.15
: ---
Assigned To: Raymond Mancy
ImplementationQuality
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 19:37 EDT by Nish Aravamudan
Modified: 2014-12-07 20:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 22:28:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nish Aravamudan 2012-05-10 19:37:21 EDT
Starting from a fresh RH6.2 installation, the Summary message is printed regularly in /var/log/httpd/error.log when using the web UI.
Comment 1 Dan Callaghan 2012-11-01 00:52:02 EDT
I think we have a similar exception related to favicon.ico, though I don't have it to hand right now.
Comment 3 Dan Callaghan 2013-08-09 00:38:18 EDT
I can't reproduce this. I don't think we have done anything to explicitly fix it though...

The path /bkr/tg_widgets/turbogears.widgets/spinnerstopped.png certainly exists, so long as server.webpath is set to '/bkr/' and the WSGI application is mounted at /bkr/ (as in the default packaged configuration).
Comment 4 Dan Callaghan 2013-08-09 00:46:08 EDT
... oops, scratch that. The problem is the system page generates a link to /bkr/bkr/tg_widgets/turbogears.widgets/spinnerstopped.png.

Seems like it might be related to http://trac.turbogears.org/ticket/1009#comment:7
Comment 5 Raymond Mancy 2013-08-09 01:43:59 EDT
OK so the problem here comes about when you are using 'server.webpath' (which we advise to do in our admin guide when not wanting to mount Beaker at the root of the webserver).

There are a couple of widgets (The AutoComplete* ones in turbogears.widgets.big_widgets) that use tg.url like thus:

  tg.url([tg.widgets, 'turbogears.widgets/spinnerstopped.png'])

And,  tg.widgets == tg.startup.webpath == server.webpath(in the config),
so we are getting 'bkr/' prepended from tg.widgets, and then '/bkr' prepended from tg.url().

The solution here is to remove the 'tg.widgets' in the params to tg.url() and only pass the subsequent string.
Comment 6 Raymond Mancy 2013-08-13 01:44:22 EDT
On gerrit:

http://gerrit.beaker-project.org/#/c/2159/
Comment 8 xjia 2013-08-21 08:22:04 EDT
Verify:
Before update, open: http://10.3.1.32/bkr/view/test1 

Aug 21 05:10:02 beaker-server beaker-server[18976]: cherrypy.msg INFO HTTP: Page handler: "The path '/bkr/tg_widgets/turbogears.widgets/spinnerstopped.png' was not found."
Aug 21 05:10:02 beaker-server beaker-server[18976]:  Traceback (most recent call last):
Aug 21 05:10:02 beaker-server beaker-server[18976]:    File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cphttptools.py", line 121, in _run
Aug 21 05:10:02 beaker-server beaker-server[18976]:      self.main()
Aug 21 05:10:02 beaker-server beaker-server[18976]:    File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cphttptools.py", line 256, in main
Aug 21 05:10:02 beaker-server beaker-server[18976]:      page_handler, object_path, virtual_path = self.mapPathToObject(path)
Aug 21 05:10:02 beaker-server beaker-server[18976]:    File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cphttptools.py", line 326, in mapPathToObject
Aug 21 05:10:02 beaker-server beaker-server[18976]:      raise cherrypy.NotFound(objectpath)
Aug 21 05:10:02 beaker-server beaker-server[18976]:  NotFound: 404
After update: open:http://10.3.1.32/bkr/view/test1

no such error.
Comment 9 xjia 2013-08-21 08:22:29 EDT
Version:
beaker-0.14.1-1.git.58.b52f89a.el6.noarch
beaker-server-0.14.1-1.git.58.b52f89a.el6.noarch
Comment 10 Nick Coghlan 2013-10-02 22:28:16 EDT
Beaker 0.15 has been released.

Note You need to log in before you can comment on or make changes to this bug.