Bug 820776 - beaker-proxy becomes a zombie regularly
beaker-proxy becomes a zombie regularly
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 19:39 EDT by Nish Aravamudan
Modified: 2012-08-28 22:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 22:38:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nish Aravamudan 2012-05-10 19:39:03 EDT
Particularly when some command throws an exception internal to beaker, but not always only then, beaker-proxy shows up as "[defunct]" in `ps aux` and a `service beaker-proxy restart` is needed. Nothing shows up in proxy.log.
Comment 1 Dan Callaghan 2012-05-13 23:58:30 EDT
The beaker-proxy daemon is a forking XMLRPC server, it forks a new process for every request (not very efficient, and I would like to change that, but that's a separate issue). The zombie processes you are seeing are probably those request handling processes, in which case it is perfectly normal and not a bug.

If the *main* beaker-proxy process is dying then that is a bug. If that is indeed happening, you could try running beaker-proxy in the foreground (-f) and see if anything useful is printed to stderr.

Note You need to log in before you can comment on or make changes to this bug.