Bug 820793 - unable to collect inventory from ppc64 system running RH6.3
unable to collect inventory from ppc64 system running RH6.3
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: tests (Show other bugs)
0.9
ppc64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
tools-bugs
Inventory
:
: 867601 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 21:09 EDT by Nish Aravamudan
Modified: 2018-02-05 19:41 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 03:10:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nish Aravamudan 2012-05-10 21:09:59 EDT
./pushInventory.py -d
Traceback (most recent call last):
  File "./pushInventory.py", line 463, in <module>
    main()
  File "./pushInventory.py", line 444, in main
    legacy_inv = legacy_inventory(inventory)
  File "./pushInventory.py", line 237, in legacy_inventory
    data['CPUSPEED'] = int(inv['Cpu']['speed'])
ValueError: invalid literal for int() with base 10: '3360.000000MHz'
Comment 1 Nish Aravamudan 2012-05-15 14:40:54 EDT
If I manually change pushInventory.py:237 to
float(inv['Cpu']['speed'][:-3])

I then get

./pushInventory.py --server http://ltcfbp55a-lp2.austin.ibm.com:8000/server -h ltcfbp55a-lp3.austin.ibm.com
DISK_CONTROLLER: hal-find-by-property failed: 256
sed: can't read /etc/multipath.conf: No such file or directory
ok
Stopping multipathd daemon: [  OK  ]
Starting multipathd daemon: [  OK  ]
MULTIPATH: multipath -ll failed with 256
Traceback (most recent call last):
  File "./pushInventory.py", line 463, in <module>
    main()
  File "./pushInventory.py", line 458, in main
    push_inventory("legacypush", hostname, legacy_inv)
  File "./pushInventory.py", line 43, in push_inventory
    resp = getattr(session, method)(hostname, inventory)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1235, in request
    self.send_content(h, request_body)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1349, in send_content
    connection.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 908, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 780, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 739, in send
    self.connect()
  File "/usr/lib64/python2.6/httplib.py", line 720, in connect
    self.timeout)
  File "/usr/lib64/python2.6/socket.py", line 567, in create_connection
    raise error, msg
socket.error: [Errno 113] No route to host

Ah, this is because iptables seems to be turning itself back on magically. Disabling it again manually gives:

./pushInventory.py --server http://ltcfbp55a-lp2.austin.ibm.com:8000/server -h ltcfbp55a-lp3.austin.ibm.com
DISK_CONTROLLER: hal-find-by-property failed: 256
sed: can't read /etc/multipath.conf: No such file or directory
ok
Stopping multipathd daemon: [  OK  ]
Starting multipathd daemon: [  OK  ]
MULTIPATH: multipath -ll failed with 256
Traceback (most recent call last):
  File "./pushInventory.py", line 463, in <module>
    main()
  File "./pushInventory.py", line 458, in main
    push_inventory("legacypush", hostname, legacy_inv)
  File "./pushInventory.py", line 43, in push_inventory
    resp = getattr(session, method)(hostname, inventory)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1392, in _parse_response
    return u.close()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 838, in close
    raise Fault(**self._stack[0])
xmlrpclib.Fault: <Fault 1: "<type 'exceptions.ValueError'>:invalid literal for int() with base 10: '1.0 (pvr 004a 0100)'">
Comment 2 Nish Aravamudan 2012-05-15 21:09:18 EDT
If I remove the legacy push of inventory, I get:

./pushInventory.py --server http://ltcfbp55a-lp2.austin.ibm.com:8000/server -h ltcfbp55a-lp3.austin.ibm.com
DISK_CONTROLLER: hal-find-by-property failed: 256
sed: can't read /etc/multipath.conf: No such file or directory
ok
Stopping multipathd daemon: [  OK  ]
Starting multipathd daemon: [  OK  ]
MULTIPATH: multipath -ll failed with 256
Traceback (most recent call last):
  File "./pushInventory.py", line 463, in <module>
    main()
  File "./pushInventory.py", line 459, in main
    push_inventory("push", hostname, inventory)
  File "./pushInventory.py", line 43, in push_inventory
    resp = getattr(session, method)(hostname, inventory)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1392, in _parse_response
    return u.close()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 838, in close
    raise Fault(**self._stack[0])
xmlrpclib.Fault: <Fault 1: "<class 'sqlalchemy.orm.exc.NoResultFound'>:No row was found for one()">
Comment 3 Dan Callaghan 2012-10-17 18:09:17 EDT
*** Bug 867601 has been marked as a duplicate of this bug. ***
Comment 4 andrew 2012-10-17 18:12:24 EDT
(In reply to comment #3)
> *** Bug 867601 has been marked as a duplicate of this bug. ***

I also get this error on 
[root@ibm-p740-01-lp5 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.0 (Santiago)
Comment 5 Bill Peck 2012-10-25 15:43:30 EDT
http://gerrit.beaker-project.org/#/c/1441/
Comment 6 andrew 2012-11-14 09:16:45 EST
(In reply to comment #5)
> http://gerrit.beaker-project.org/#/c/1441/

I can confirm that the new inventory that bill made works. This has been tested on 15 different lpars.
Comment 7 Dan Callaghan 2013-06-20 03:10:38 EDT
This was fixed in /distribution/inventory 1.1-61.

Note You need to log in before you can comment on or make changes to this bug.