This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 82085 - Mozilla Japanese font is very dirty
Mozilla Japanese font is very dirty
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-17 04:49 EST by Nakai
Modified: 2007-04-18 12:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-30 06:18:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mozdirty.png (60.33 KB, image/png)
2003-01-17 04:53 EST, Nakai
no flags Details

  None (edit)
Description Nakai 2003-01-17 04:49:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
When I input Japanese string into html form with Mozilla,
it shows very dirty fonts.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Input Japanese string into http://www.google.com/ form with mozilla
2. Japanese 'aaaaa'
3. Dirty
    

Additional info:
Comment 1 Nakai 2003-01-17 04:53:05 EST
Created attachment 89418 [details]
mozdirty.png
Comment 2 Nakai 2003-01-17 04:55:02 EST
If Hiragana is in the string, it gets very dirty.
If not, the string gets antialiased.

That's very silly behavior.
Comment 3 Christopher Blizzard 2003-01-18 10:46:19 EST
That's all Xft.
Comment 4 Leon Ho 2003-01-27 22:07:18 EST
Look like it is getting two different fonts. Is mozilla just getting the first "suitable" 
font on the list? 
Comment 5 Christopher Blizzard 2003-01-28 10:43:19 EST
Yes, that's what it does via the xft setup.
Comment 6 Owen Taylor 2003-01-28 11:08:32 EST
A) Perhaps Mozilla isn't setting the language tags for controls
   based on the language of the page? 

B) Does removing the fonts in /usr/share/fonts/ja/misc improve
   the situation?

C) Does removing bitmap-fonts-cjk improve the situation (if you
   have that installed?)
Comment 7 Leon Ho 2003-01-28 22:57:41 EST
> B) Does removing the fonts in /usr/share/fonts/ja/misc improve the situation? 
mv /usr/share/fonts/ja/misc /tmp; still the same 
 
> C) Does removing bitmap-fonts-cjk improve the situation (if you have that 
installed?) 
 
Same- However I have tested around on which fonts that effect the selections: *if* i 
remove console* in /usr/share/fonts/bitmap-fonts/ then the display and font 
selection will look much better (will only select ttf font so that we could not see the 
rendering problem of console glyphs). We may have two folds the problem - one 
may related to ways of only return a font with nearest to fullset of the charset. 
Another one is the rendering problem on the console font(?) 
Comment 8 Christopher Blizzard 2003-01-29 10:42:39 EST
> A) Perhaps Mozilla isn't setting the language tags for controls
>    based on the language of the page? 

As far as I know, it is.
Comment 9 Nakai 2003-01-30 06:18:17 EST
Seems to be fixed in Phoebe4 + mozilla 1.2.1-15

Note You need to log in before you can comment on or make changes to this bug.