Bug 820856 - Exceptional average report in mpstat
Exceptional average report in mpstat
Status: CLOSED DUPLICATE of bug 820507
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sysstat (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Schiffer
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 04:26 EDT by Quan Wenli
Modified: 2012-06-19 06:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 06:55:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result show on "mpstat 1 59 " (5.40 KB, text/plain)
2012-05-11 04:26 EDT, Quan Wenli
no flags Details

  None (edit)
Description Quan Wenli 2012-05-11 04:26:30 EDT
Created attachment 583761 [details]
result show on "mpstat 1 59 "

Description of problem:
when doing performance testing of kvm network, we usually use mpstat to measure the cpu usage on host.sometimes exceptional average report is showed like "Average:     all    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00"

Version-Release number of selected component (if applicable):

sysstat-9.0.4-20.el6.x86_64


How reproducible:
sometimes

Steps to Reproduce:
1.boot up a guest
2.do netperf tests on guest,at the same time. measure cpu usage on host by using "mpstat 1 59"
3.check the attached the result 
  
Actual results:


Expected results:

cpu average can be computed well.

Additional info:
Comment 3 Peter Schiffer 2012-06-14 09:19:07 EDT
Quan,

please, was this issue also fixed in kernel-2.6.32-275.el6 (as the result of bug #820507)?

Thanks,

peter
Comment 4 Quan Wenli 2012-06-18 01:36:59 EDT
(In reply to comment #3)
> Quan,
> 
> please, was this issue also fixed in kernel-2.6.32-275.el6 (as the result of
> bug #820507)?
> 
> Thanks,
> 
> peter

Yes, did not hit this issue in kernel-2.6.32-277.el6.
But I am interesting in how does average of mpstat computed, bug #820507 will only affect result of certain seconds, why all "zero" show in the average report.
Comment 5 Peter Schiffer 2012-06-18 07:35:11 EDT
Hi Quan,

the average is counted the same way as the rest of the statistics - difference between the two values; for average it is the first and last value. Also, there is the check whether the first value is not bigger than the second, what could happen with bug #820507.. so I think the zero average is from there..

Can I close this bug as a duplicate?

Thanks,

peter
Comment 6 Quan Wenli 2012-06-19 00:58:08 EDT
(In reply to comment #5)
> Hi Quan,
> 
> the average is counted the same way as the rest of the statistics -
> difference between the two values; for average it is the first and last
> value. Also, there is the check whether the first value is not bigger than
> the second, what could happen with bug #820507.. so I think the zero average
> is from there..
Thanks for your comment.
> Can I close this bug as a duplicate?
Yes,pease.
> Thanks,
> 
> peter
Comment 7 Peter Schiffer 2012-06-19 06:55:59 EDT

*** This bug has been marked as a duplicate of bug 820507 ***

Note You need to log in before you can comment on or make changes to this bug.