Bug 820899 - SW-Update blocked : yum cannot recover from error
SW-Update blocked : yum cannot recover from error
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 06:23 EDT by hp4
Modified: 2014-01-21 18:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 15:51:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hp4 2012-05-11 06:23:09 EDT
Description of problem:
During normal SW-update an error occurred due to missing disk space. Restart with more disk space is not possible due to pending transactions.

Version-Release number of selected component (if applicable):


How reproducible:
Start update in low-disk-space environment and wait for termination with error. Then supply more disk space and restart SW-update. This yields an initialisation error with the hint to solve the problem by running

yum-complete-transaction

But the problem isn't solved: instead 3 errors are reported as shown below 

Steps to Reproduce:
1. Start normal SW-Update -> error with initialisation-error  
2. yum-complete-transaction -> error messages below
3. yum-complete-transaction --skip-broken -> same error messages
  
Actual results:
.....
Fehler: Paket: kernel-PAE-3.3.4-3.fc16.i686 (updates)
            Benötigt: dracut >= 001-7
            Entfernen: dracut-013-22.fc16.noarch (@updates)
                dracut = 013-22.fc16
            Verfügbar: dracut-013-18.fc16.noarch (fedora)
                dracut = 013-18.fc16
Fehler: Paket: kernel-PAE-3.3.4-3.fc16.i686 (updates)
            Benötigt: linux-firmware >= 20120206-0.1.git06c8f81
            Entfernen: linux-firmware-20120206-0.1.git06c8f81.fc16.noarch (@updates)
                linux-firmware = 20120206-0.1.git06c8f81.fc16
            Verfügbar: linux-firmware-20110731-2.fc16.noarch (fedora)
                linux-firmware = 20110731-2.fc16
Fehler: Paket: kernel-PAE-3.3.4-3.fc16.i686 (updates)
            Benötigt: initscripts >= 8.11.1-1
            Entfernen: initscripts-9.34.2-1.fc16.i686 (@updates)
                initscripts = 9.34.2-1.fc16
            Verfügbar: initscripts-9.33-1.fc16.i686 (fedora)
                initscripts = 9.33-1.fc16
 Sie können versuchen mit --skip-broken das Problem zu umgehen.
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

yum-complete-transaction should be able to handle interrupted transactions. 

Additional info:
Comment 1 hp4 2012-06-15 13:10:53 EDT
Is there anyone responsible for yum?


Error message is:

Trying to remove 'yum,' which is protected.
==========================================

Does yum try to remove itself ???????


In the meantime I've found a similar problem reported on the net:



http://www.centos.org/modules/newbb/print.php?form=1&topic_id=37662&forum=55&order=DESC&start=0
Comment 2 Fedora End Of Life 2013-01-16 11:49:23 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora End Of Life 2013-02-13 15:51:37 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.