Bug 820971 - Help -> Contents function is broken
Help -> Contents function is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: simple-scan (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-05-11 09:10 EDT by Petr Schindler
Modified: 2012-05-15 01:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: simple-scan-3.4.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 01:26:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2012-05-11 09:10:04 EDT
Description of problem:
This is what Help application says after I try to get help (by choosing Help->Content or by pressing F1 key):

Document Not Found
The URI ‘ghelp:simple-scan’ does not point to a valid page.

Version-Release number of selected component (if applicable):
simple-scan-3.4.0-1.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run simple-scan
2. press f1
3.
  
Actual results:
Help isn't shown

Expected results:
Help is shown

Additional info:
Because simple-scan is installed by default (when installing from DVD), I
propose this bug as final blocker per criterion:
 "Menu sanity - the following criteria refer to both a live image and default
installed system, and to all release-blocking desktops: "
 - All applications listed under the Applications menu or category must
withstand a basic functionality test and not crash after a few minutes of
normal use. They must also have working Help and Help -> About menu items
Comment 1 Fedora Update System 2012-05-11 19:09:42 EDT
simple-scan-3.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/simple-scan-3.4.1-1.fc17
Comment 2 Adam Williamson 2012-05-11 21:00:33 EDT
Discussed at 2012-05-11 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-05-11/f17-final-blocker-review-meeting-5.2012-05-11-17.04.html . This was accepted as a blocker per criterion "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Fedora Update System 2012-05-12 12:20:49 EDT
Package simple-scan-3.4.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing simple-scan-3.4.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7741/simple-scan-3.4.1-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-05-15 01:26:41 EDT
simple-scan-3.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.