Bug 821010 - handle error case when cdn is unreachable to get available release versions
handle error case when cdn is unreachable to get available release versions
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Tom McKay
SAM QE List
: Triaged
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-05-11 10:49 EDT by Tom McKay
Modified: 2012-06-20 11:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the CDN is not reachable or an error occurs getting the available release versions, the System/Details page is not usable and the "Release Version" dropdown menu is blank.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:20:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-05-11 10:49:13 EDT
Description of problem:
If the CDN is not reachable or an error occurs getting the available release versions, the System/Details page is not usable. A safeguard needs to be put in place for this case.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Put in a bad Repository Url on the Red Hat Provider page
2. Attempt to visit a system's Details page
3.
  
Actual results:
Cannot visit page

Expected results:
Able to visit page (w/ indication that something failed?)

Additional info:
Comment 1 Tom McKay 2012-05-14 12:50:44 EDT
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 27d783d85afb62ad6fcb73fd36a64691d976d988
      https://github.com/Katello/katello/commit/27d783d85afb62ad6fcb73fd36a64691d976d988
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2012-05-14 (Mon, 14 May 2012)

For testing: Change the Repository URL on the Red Hat Provider page to a bad url, then visit a system's Details page. Note error message in log and no choices when editing release version.
Comment 3 Eric Sammons 2012-06-01 13:31:38 EDT
As a sysadmin I would like feedback as to why I see no releases in my Release Version drop down on my details tab when my cdn is unreachable.

katello-cli-common-0.3.4-1.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch
katello-glue-candlepin-0.3.2-1.el6_2.noarch
thumbslug-0.0.24-1.el6_2.noarch
katello-configure-0.3.7-1.el6_2.noarch
katello-headpin-all-0.2.11-1.el6_2.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch
elasticsearch-0.18.4-11.el6.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-common-0.3.2-1.el6_2.noarch
katello-headpin-0.2.11-1.el6_2.noarch
katello-cli-headpin-0.2.2-1.el6_2.noarch
candlepin-tomcat6-0.6.5-1.el6_2.noarch


CDN outages can occur and it could be that I have specified a bad cdn, I'd like to know that something is wrong to explain why I see nothing in my drop down.  A blank drop down doesn't tell me anything.
Comment 4 sachua 2012-06-14 01:16:29 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
If the CDN is not reachable or an error occurs getting the available release versions, the System/Details page is not usable and the "Release Version" dropdown menu is blank.
Comment 6 errata-xmlrpc 2012-06-20 11:20:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1021.html

Note You need to log in before you can comment on or make changes to this bug.