Bug 821013 - cling allocation policy should never split data across PVs
cling allocation policy should never split data across PVs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.8
All All
medium Severity medium
: rc
: ---
Assigned To: Alasdair Kergon
Cluster QE
:
Depends On: 821007
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 10:54 EDT by Alasdair Kergon
Modified: 2013-01-08 02:11 EST (History)
11 users (show)

See Also:
Fixed In Version: lvm2-2.02.88-9.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 821007
Environment:
Last Closed: 2013-01-08 02:11:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alasdair Kergon 2012-05-11 10:54:13 EDT
+++ This bug was initially created as a clone of Bug #821007 +++

The 'cling' allocation policy is behaving like the 'normal' policy when there is no pre-existing preceding segment to cling to.

Example:
Use lvcreate with --alloc cling to create a linear device that fits within the VG but is too large to fit on any single PV in the VG.  It succeeds, placing the data across multiple PVs.  It should fail.
Comment 1 RHEL Product and Program Management 2012-05-11 10:57:33 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Nenad Peric 2012-08-13 07:16:56 EDT
Tested reproducer with old version of lvm:


[root@r5-node01:/etc/yum.repos.d]$ vgcreate test_vg /dev/sdc1 /dev/sdd1
  Clustered volume group "test_vg" successfully created

[root@r5-node01:~]$ lvcreate --alloc cling test_vg -n bigger_lv -L 15G
  Logical volume "bigger_lv" created



Updated lvm to lvm2-2.02.88-8.el5.x86_64 and tested again:

[root@r5-node01:~]$ vgcreate test_vg /dev/sdc1 /dev/sdd1
  Clustered volume group "test_vg" successfully created
[root@r5-node01:~]$ lvcreate --alloc cling test_vg -n bigger_lv -L 15G
  Insufficient suitable allocatable extents for logical volume bigger_lv: 1281 more required

The creation fails as expected. Marking as verified.

Packages installed

before:

lvm2-2.02.88-8.el5
lvm2-cluster-2.02.88-8.el5

after update:

lvm2-cluster-2.02.88-9.el5
lvm2-2.02.88-9.el5
Comment 5 errata-xmlrpc 2013-01-08 02:11:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0023.html

Note You need to log in before you can comment on or make changes to this bug.