Bug 821024 - Opening preferences dialog after closing with ESC fails.
Opening preferences dialog after closing with ESC fails.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Michael Stead
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-11 11:35 EDT by Michael Stead
Modified: 2012-06-20 08:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preferences dialog does not open correctly. (43.28 KB, image/png)
2012-05-11 11:37 EDT, Michael Stead
no flags Details

  None (edit)
Description Michael Stead 2012-05-11 11:35:24 EDT
Description of problem:
The preference dialog does not open correctly if it was previously closed by pressing the ESC key.


How reproducible:
Always

Steps to Reproduce:
1. Open the preference dialog by clicking on the toolbar button.
2. Close the dialog by pressing the ESC key.
3. Re-open the preferences dialog.
  
Actual results:
Preferences dialog does not open correctly. See attached screenshot.


Expected results:
The preference dialog should open as it did initially.


Additional info:
Comment 1 Michael Stead 2012-05-11 11:37:17 EDT
Created attachment 583874 [details]
Preferences dialog does not open correctly.
Comment 2 Michael Stead 2012-05-11 15:12:38 EDT
Fixed in:
RHEL6.3 - b933c304064f0ed5a66015c60ab70f9e749b5761
master - 746396899f5f831bdd8d13db9ef1e740a8aa8013
Comment 5 John Sefler 2012-05-22 10:56:22 EDT
Verifying RHEL63 Version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.99.18-1.el6.x86_64

Manual verification using the <Esc> key as well as the accelerator (<Alt>C) will successfully close the system preferences dialog, retain changes to the service level setting, and then the dialog can be successfully re-opened with the toolbar button and closed again and again using the <Esc> key.  Screenshot  attachment 583874 [details] is no longer observed.

Moving to VERIFIED
Comment 8 errata-xmlrpc 2012-06-20 08:57:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.