Bug 821036 - Macaulay2: mpfr/mpir license issues
Macaulay2: mpfr/mpir license issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Macaulay2 (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 11:41 EDT by Jerry James
Modified: 2012-07-23 15:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: Macaulay2-1.4-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 15:10:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2012-05-11 11:41:44 EDT
Description of problem:
Macaulay2 is GPLv2.  It is linked with mpfr, which is "LGPLv3+ and GPLv3+
and GFDL".  Macaulay2 might also be responsible for holding back updates to mpir due to license incompatibility; see bug 680892.  Is upstream considering GPLv2+ at all?  If not, is compiling without mpfr/mpir an option?

Version-Release number of selected component (if applicable):
Macaulay2-1.4-4.fc18.x86_64

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2012-05-30 12:17:49 EDT
Upstream finally replied to my query, 

------------------
I am just now looking into this again -- thank you for the prompt.  I have just
checked in a change to the trunk expanding the statement in M2/INSTALL to
say the our source code is licensed under GPL 2 or 3 and restricting the
statement in the variable "copyright" accessible from the running M2 program
to say that the binary code is licensed under GPL 3.  That should take care of
it. 
------------------

which should resolve things
Comment 2 Rex Dieter 2012-07-23 15:10:27 EDT
* Wed May 30 2012 Rex Dieter <rdieter@fedoraproject.org>
- 1.4-5
- License: GPLv2 or GPLv3 (#821036)


Turns out we'll likely end up linking against gmp moving forward anyway, for increased compatibility with Singular (stay tuned).

Note You need to log in before you can comment on or make changes to this bug.