Bug 821043 - XMLRPC fault - Malformed sql query
XMLRPC fault - Malformed sql query
Status: CLOSED DUPLICATE of bug 821155
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks: BZ42
  Show dependency treegraph
 
Reported: 2012-05-11 11:52 EDT by Pavel Slama
Modified: 2014-10-12 18:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.2.1-0.rc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-13 18:55:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (1019 bytes, text/x-python)
2012-05-11 11:52 EDT, Pavel Slama
no flags Details

  None (edit)
Description Pavel Slama 2012-05-11 11:52:21 EDT
Created attachment 583877 [details]
reproducer

Description of problem:
bugzilla.runQuery call faults with 'DBD::mysql::st execute failed: FUNCTION bugs.0AND does not exist

Version-Release number of selected component (if applicable):
devel

How reproducible:
100%

Steps to Reproduce:
reproducer script attached 


Actual results:
DBD::mysql::st execute failed: FUNCTION bugs.0AND does not exist 

* notice 0AND together in the statement

..(SELECT bug_id FROM flags INNER JOIN flagtypes ON flags.type_id = flagtypes.id WHERE INSTR(CONCAT(flagtypes.name, flags.status), \'jboss-brms-5.1.0\') > 0AND (flagtypes.view_group_id IS NULL..



Expected results:
no error

Additional info:
Comment 1 Simon Green 2012-05-13 18:55:56 EDT
Will be fixed in the next release (rc3)

*** This bug has been marked as a duplicate of bug 821155 ***

Note You need to log in before you can comment on or make changes to this bug.