Bug 821044 - sss_groupadd no longer detects duplicate GID numbers
Summary: sss_groupadd no longer detects duplicate GID numbers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Stephen Gallagher
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-11 15:58 UTC by Jakub Hrozek
Modified: 2020-05-02 16:53 UTC (History)
4 users (show)

Fixed In Version: sssd-1.8.0-27.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Clone Of:
Environment:
Last Closed: 2012-06-20 11:44:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 2377 0 None None None 2020-05-02 16:53:19 UTC
Red Hat Product Errata RHBA-2012:0747 0 normal SHIPPED_LIVE sssd bug fix and enhancement update 2012-06-19 19:31:43 UTC

Description Jakub Hrozek 2012-05-11 15:58:58 UTC
Description of problem:
In 6.2, sss_groupadd used to warn if there was a duplicate name or GID. sss_groupadd no longer warns about duplicate GID numbers in 6.3

Version-Release number of selected component (if applicable):
1.8.0-25

How reproducible:
always

Steps to Reproduce:
1. sss_groupadd -g 1234 groupone
2. sss_groupadd -g 1234 grouptwo
3.
  
Actual results:
groupone disappears from the cache, grouptwo is saved with requested GID of 1234. No warning issues

Expected results:
grouptwo should not be added and sss_groupadd should print a warning

Additional info:
This is a regression caused by a fix for https://bugzilla.redhat.com/show_bug.cgi?id=746181

When QE tests this bug, it would be prudent to retest #746181, too.

Comment 1 Jakub Hrozek 2012-05-11 16:03:03 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1335

Comment 3 Stephen Gallagher 2012-05-11 16:20:53 UTC
Patch is committed upstream

Comment 6 Kaushik Banerjee 2012-05-14 11:23:21 UTC
Verified in version sssd-1.8.0-27.


::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: SSSD local-local test 020 >>> Add LOCAL Group with gidNumber Already in Use
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Adding duplicate gidNumber error message was as expected.
'58fcab1a-be2e-421f-9bf4-a622033a8494'
SSSD-local-local-test-020-Add-LOCAL-Group-with-gidNumber-Already-in-Use result: PASS
   metric: 0

Comment 7 Stephen Gallagher 2012-06-12 12:43:43 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed

Comment 9 errata-xmlrpc 2012-06-20 11:44:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html


Note You need to log in before you can comment on or make changes to this bug.