This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 82106 - HP Deskjet 1600CM postscript printer error
HP Deskjet 1600CM postscript printer error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-17 11:36 EST by Bruce Allen
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 12:48:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of printconf-tui --Xexport (5.71 KB, text/xml)
2003-01-17 11:47 EST, Bruce Allen
no flags Details

  None (edit)
Description Bruce Allen 2003-01-17 11:36:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I am using a HP Deskjet 1600CM native postscript printer with
an internal JetDirect card (ethernet interface).  I set up a
print queue using printconf-gui, and choosing the postscript driver with all
default settings.

When I try and print a postscript test page, or any postscript file,
I get a page from the printer with the following error message:

ERROR: configurationerror
OFFENDING COMMAND: setpagedevice

STACK:

From what little I know of postscript, I think that perhaps the printer driver
is sending some commands to set the page type that are
not recognized.  Is this a known problem, and if so, is there a config option to
turn off the offending command?

 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up new printer queue, for HP Deskjet 1600CM
2. Choose jetdirect interface
3. Choose postscript driver
4. Try printing US letter postscript test page

Actual Results:  I get a page from the printer with the following error message:

ERROR: configurationerror
OFFENDING COMMAND: setpagedevice

STACK:


Expected Results:  A nice test page comes out of the printer

Additional info:

I have printed files to the printer from other machines
(eg a solaris box running HP jetadmin to manage print queues).
The printer works fine.
Comment 1 Tim Waugh 2003-01-17 11:39:05 EST
Please attach the output of 'printconf-tui --Xexport'.
Comment 2 Bruce Allen 2003-01-17 11:47:16 EST
Created attachment 89424 [details]
output of printconf-tui --Xexport

The printer causing trouble is the one with queue name dj1600
Comment 3 Tim Waugh 2003-01-17 12:08:53 EST
Does enabling the 'rerender postscript' option (in the printconf tool) help any?
Comment 4 Bruce Allen 2003-01-17 12:32:19 EST
I assume you mean "prerender postscript" not "rerender postscript".

It worked! Problem fixed.  Thank you!  Please mark bug as "resolved".

[Does this mean that the postscript interpreter inside the printer is
simply being bypassed and that the postscript interpretation is being done
"before" data is sent to the printer?]
Comment 5 Tim Waugh 2003-01-17 12:48:36 EST
Yes (actually the option has changed name since 7.3).

It means that the PostScript is converted to Level 2 using ghostscript.  The
real rendering is still done at the printer.

Okay, marking resolved.

Note You need to log in before you can comment on or make changes to this bug.