Bug 821065 - RFE: Progress spinner during GUI SLA autobind.
RFE: Progress spinner during GUI SLA autobind.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-05-11 14:05 EDT by Devan Goodwin
Modified: 2013-01-10 06:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: A progress spinner is now shown during the auto-subscribe process. Reason: Previously, the application would appear unresponsive during the auto-subscribe process. Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:52:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2012-05-11 14:05:05 EDT
Description of problem:

During GUI registration we are presented with nice spinners for slow communications with server, however as soon as we're registered and we're transitioning to the SLA autobind phase, there is a very noticeable pause with no spinner.


Version-Release number of selected component (if applicable):

1.0.1

How Reproducible:

Just need to register against production, or any other server that will take a little time to communicate with. Ideally you will have multiple SLAs on the account that will cover what is on the machine.

Steps to Reproduce:

1. Register with GUI, do not skip autosubscribe.
  
Actual results:

Long pause after registration but before the autosubscribe "choose SLA" or "confirm subscriptions" dialog appears.


Expected results:

Progress spinners throughout the autobind process as with registration.

Additional info:

Very slow here as we have to ask the server to give results of a dry-run autobind for every available SLA.
Comment 1 James Bowes 2012-07-10 13:03:26 EDT
Fixed in master, 3a2859f
Comment 3 Sharath Dwaral 2012-08-02 11:17:36 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.0.11-1.git.10.ac56ecc.el5
subscription-manager-migration-1.0.11-1.git.10.ac56ecc.el5
subscription-manager-firstboot-1.0.11-1.git.10.ac56ecc.el5
subscription-manager-gui-1.0.11-1.git.10.ac56ecc.el5
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
python-rhsm-1.0.4-1.git.7.47e5112.el5

Verification:
The spinners are present throught out registration process and also during autosubscribe. 

>During the autosubscribe phase the spinner hangs (ignoring this and Verifying the bug)

Moving the bug to VERIFIED
Comment 5 errata-xmlrpc 2013-01-07 22:52:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.