Bug 821072 - gnome-panel-3.2.1-2.fc16.x86_64 crashes on login
gnome-panel-3.2.1-2.fc16.x86_64 crashes on login
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 14:22 EDT by Tim Zorn
Modified: 2013-02-13 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 17:09:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.92 KB, text/plain)
2012-05-11 14:22 EDT, Tim Zorn
no flags Details
Xorg.0.log (64.66 KB, text/plain)
2012-05-11 14:23 EDT, Tim Zorn
no flags Details
.xsession-errors (2.23 KB, text/plain)
2012-05-11 14:23 EDT, Tim Zorn
no flags Details
/etc/sysconfig/desktop (35 bytes, application/octet-stream)
2012-05-11 14:38 EDT, Tim Zorn
no flags Details

  None (edit)
Description Tim Zorn 2012-05-11 14:22:20 EDT
Created attachment 583898 [details]
xorg.conf

Description of problem:

GNOME does not load properly with my setup in xorg.conf
KDE does, however, start properly so I know it isn't an X server problem.


Version-Release number of selected component (if applicable):

gnome-panel-3.2.1-2.fc16.x86_64

How reproducible:

everytime

Steps to Reproduce:
1. Have 2 AMD Graphics cards
2. use fglrx
3. have one graphics card without 3D acceleration and one with
4. login
  
Actual results:

You just see the background (no panel, nothing but the background)

Expected results:

To see GNOME and all its goodness

Additional info:
Comment 1 Tim Zorn 2012-05-11 14:23:18 EDT
Created attachment 583899 [details]
Xorg.0.log
Comment 2 Tim Zorn 2012-05-11 14:23:55 EDT
Created attachment 583900 [details]
.xsession-errors
Comment 3 Tim Zorn 2012-05-11 14:26:52 EDT
More explanation:

I'm using two different AMD graphics cards that are not running in Crossfire.
If I load GNOME with just the older card it falls back to the older GNOME.
If I load Gnome with just the newer card everything loads fine.

GNOME will not start with both cards running.

KDE (and XFCE4), however, load fine.



Side-question:
Can I run the newer GNOME on one monitor and the older GNOME on another (currently there is one monitor outputting per graphics card)?
Comment 4 Tim Zorn 2012-05-11 14:38:07 EDT
Created attachment 583905 [details]
/etc/sysconfig/desktop
Comment 5 Tim Zorn 2012-05-11 14:39:23 EDT
Comment on attachment 583905 [details]
/etc/sysconfig/desktop

Oops. Didn't mean to put this here.
Comment 6 Tim Zorn 2012-05-11 14:41:47 EDT
Also, I ran "gsettings set org.gnome.desktop.session session-name 'gnome-fallback'" because I thought it would make it work. (it didn't load before that either)
Comment 7 Milan Bouchet-Valat 2012-05-12 04:19:21 EDT
That's a crash in gnome-panel:
(gnome-panel:3809): Gtk-CRITICAL **: gtk_style_context_get: assertion `priv->widget_path != NULL' failed
gnome-session[3572]: WARNING: Application 'gnome-panel.desktop' killed by signal

Can you start abrt-gui and see whether there's a crash waiting to be reported in the list?
Comment 8 Tim Zorn 2012-05-12 04:42:39 EDT
There was a crash waiting to be reported.
However, when I tired to report it I got "Reporting disabled because the backtrace is unusable"
Comment 9 Milan Bouchet-Valat 2012-05-12 06:06:27 EDT
Maybe you can reproduce the problem and try again? Be sure to install all package updates first.
Comment 10 Tim Zorn 2012-05-12 14:41:04 EDT
I've been messing around with xorg.conf and I have a version that works.
It loads into GNOME but as fallback (because enabling xinerama disables 3D acceleration support)

I am now thinking that my other card might actually support 3D acceleration. I was wondering if there is a way to do something similar to Xinerama but that allows 3D acceleration.

Here are the changes I mage:

[root@localhost ~]# diff /etc/X11/xorg.conf --from-file=old.xorg.conf
4c4,5
< 	Screen         "aticonfig-Screen[1]-0" 1600 0
---
> 	Screen      1  "aticonfig-Screen[1]-0" RightOf "aticonfig-Screen[0]-0"
> 	Option	    "Xinerama" "on"
9a11,14
> Section "ServerFlags"
> 	Option	    "Xinerama" "on"
> EndSection
> 
31c36
< 	Option	    "Position" "0 0"
---
> #	Option	    "Position" "0 0"
42c47
< 	Option	    "Position" "0 0"
---
> #	Option	    "Position" "0 0"
Comment 11 Fedora End Of Life 2013-01-16 12:27:37 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Fedora End Of Life 2013-02-13 17:09:24 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.