Bug 821086 - Create new VM and edit the memory field in Power User Portal and cursor moves to end of field.
Create new VM and edit the memory field in Power User Portal and cursor moves...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.0.3
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tomas Jelinek
Tomas Dosek
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 16:16 EDT by Bill Sanford
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: si8 rhevm-userportal-3.1.0-3.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:59:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-05-11 16:16:49 EDT
Description of problem:
In the Power User Portal, if you add a new VM (Server or Desktop) and you edit the "Memory Size," every time you add or delete a character, the cursor goes to the end of the editable field. 

Version-Release number of selected component (if applicable):
RHEV-M ic155.2

How reproducible:
100%

Steps to Reproduce:
1. In Power User Portal, create new server or desktop.
2. Edit the numeric value in the Memory field with backspace or delete keys.
3.
  
Actual results:
Cursor goes to the end of the editable field

Expected results:
Cursor should remain where it is.

Additional info:
Comment 1 Tomas Jelinek 2012-06-21 03:29:27 EDT
I can not simulate this on git: c8bc4415d80e0f74efce7e9de8b4c6f1f41a5718
Does this still reproduce?
Comment 2 Barak 2012-07-04 08:03:33 EDT
Usually I would have changed the status to CLOSED CURRENT_RELEASE, but I want the QE to verify this problem does not exist any more, so moving it to ON_QE

Einav: this problem has been solved once the infrastructure for webadmin and userportal were unified.
Comment 3 Yaniv Kaul 2012-07-05 03:21:57 EDT
Bill - are you seeing it with 3.1 webadmin?
Comment 4 Bill Sanford 2012-07-11 09:10:21 EDT
I haven't tried it with 3.1 webadmin, yet. I will look for this on the next install of 3.1.
Comment 5 Tomas Dosek 2012-07-12 01:48:54 EDT
Verified - si9.1 - this behaviour cannot be reproduced on the newest build of RHEV-M User Portal and Webadmin. Editing of Memory field has no negative effect on other fields of edit dialogue.

Note You need to log in before you can comment on or make changes to this bug.