Bug 821106 - Need iproute-devel packaged as well as iproute
Summary: Need iproute-devel packaged as well as iproute
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iproute
Version: 6.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: David Spurek
URL:
Whiteboard:
Depends On:
Blocks: 836169
TreeView+ depends on / blocked
 
Reported: 2012-05-11 22:37 UTC by Philip Prindeville
Modified: 2015-03-02 05:26 UTC (History)
4 users (show)

Fixed In Version: iproute-2.6.32-21.el6
Doc Type: Bug Fix
Doc Text:
Cause The iproute package was distributed without the libnetlink library. Consequence It wasn't possible for EL users to utilize the libnetlink library features. Change The libnetlink library is now included in the newly introduced devel subpackage. Result EL users can now utilize libnetlink features.
Clone Of:
Environment:
Last Closed: 2013-02-21 10:23:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
Build EL from Fedora's branch of iproute but omit linux-atm stuff (which hasn't been ported) (819 bytes, application/octet-stream)
2012-05-11 22:37 UTC, Philip Prindeville
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0417 normal SHIPPED_LIVE iproute bug fix and enhancement update 2013-02-20 20:49:52 UTC

Description Philip Prindeville 2012-05-11 22:37:31 UTC
Created attachment 583944 [details]
Build EL from Fedora's branch of iproute but omit linux-atm stuff (which hasn't been ported)

Description of problem:

The libnetlink.a library (and headers) is built as part of iproute in Fedora. I've some programs I'd like to backport to CentOS/RHEL but can't because of the lack of these files.

Can we switch RHEL to share iproute with Fedora?


Version-Release number of selected component (if applicable):

2.6.32-17

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Petr Šabata 2012-05-14 09:24:12 UTC
This is a minimal, non-disruptive change.
Requesting acks.

Comment 3 Philip Prindeville 2012-06-02 21:27:28 UTC
(In reply to comment #2)
> This is a minimal, non-disruptive change.
> Requesting acks.

Sorry, requesting from whom?

Comment 4 Petr Šabata 2012-06-04 11:14:25 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > This is a minimal, non-disruptive change.
> > Requesting acks.
> 
> Sorry, requesting from whom?

Just getting the bug approved for the next release :)

Comment 8 Petr Šabata 2012-08-29 15:20:40 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    The iproute package was distributed without the libnetlink library.
Consequence
    It wasn't possible for EL users to utilize the libnetlink library features.
Change
    The libnetlink library is now included in the newly introduced devel subpackage.
Result
    EL users can now utilize libnetlink features.

Comment 14 Petr Šabata 2012-10-09 12:03:36 UTC
Temporary switching to MODIFIED for ET.

Comment 18 errata-xmlrpc 2013-02-21 10:23:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0417.html


Note You need to log in before you can comment on or make changes to this bug.