Bug 821122 - repoclosure failure on 17.TC5 DVDs (zif)
repoclosure failure on 17.TC5 DVDs (zif)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: zif (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-05-12 03:57 EDT by Andre Robatino
Modified: 2012-05-16 02:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 02:07:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "ls *" in the Packages/ directory (125.80 KB, text/plain)
2012-05-14 04:33 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2012-05-12 03:57:21 EDT
Description of problem:
17.TC5 i386 DVD:

package: PackageKit-zif-0.7.4-1.fc17.i686 from myrepo
  unresolved deps: 
     PackageKit = 0:0.7.4-1.fc17

17.TC5 x86_64 DVD:

package: PackageKit-zif-0.7.4-1.fc17.x86_64 from myrepo
  unresolved deps: 
     PackageKit = 0:0.7.4-1.fc17
Comment 1 Adam Williamson 2012-05-12 20:44:43 EDT
we requested 0.7.4-2.fc17 for TC5, so I guess somehow the zif subpackage didn't get on the DVDs? Or did both PackageKit-zif-0.7.4-1.fc17 and PackageKit-zif-0.7.4-2.fc17 wind up on there?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Richard Hughes 2012-05-14 04:22:51 EDT
Can we get a package list of the things on the DVD? Thanks.
Comment 3 Andre Robatino 2012-05-14 04:33:25 EDT
Created attachment 584285 [details]
output of "ls *" in the Packages/ directory
Comment 4 Andre Robatino 2012-05-14 04:36:28 EDT
The above list is for i386. I can also provide output for x86_64 if necessary (though I doubt it since it looks like the breakage is the same for both arches).
Comment 5 Kalev Lember 2012-05-14 04:54:35 EDT
Looks like a failure with mash and/or side repos used for pulling in extra packages to the compose. Likely to get fixed with next stable push that includes the PackageKit 0.7.4-2 build.
Comment 6 Adam Williamson 2012-05-14 11:42:13 EDT
Note the presence of both 0.7.4-1 and 0.7.4-2 RPMs for PK itself.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Tim Flink 2012-05-14 14:47:30 EDT
Discussed at the 2012-05-14 mini blocker review meeting. Accepted as a blocker for Fedora 17 final due to violation of the following Fedora 17 alpha release criterion [1]:

"There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"

[1] http://fedoraproject.org/wiki/Fedora_17_Alpha_Release_Criteria
Comment 8 Andre Robatino 2012-05-16 02:07:08 EDT
Fixed in 17.TC6. No repoclosure problems.

Note You need to log in before you can comment on or make changes to this bug.