Bug 821122 - repoclosure failure on 17.TC5 DVDs (zif)
Summary: repoclosure failure on 17.TC5 DVDs (zif)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: zif
Version: 17
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On:
Blocks: F17Blocker, F17FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2012-05-12 07:57 UTC by Andre Robatino
Modified: 2012-05-16 06:07 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-05-16 06:07:08 UTC


Attachments (Terms of Use)
output of "ls *" in the Packages/ directory (125.80 KB, text/plain)
2012-05-14 08:33 UTC, Andre Robatino
no flags Details

Description Andre Robatino 2012-05-12 07:57:21 UTC
Description of problem:
17.TC5 i386 DVD:

package: PackageKit-zif-0.7.4-1.fc17.i686 from myrepo
  unresolved deps: 
     PackageKit = 0:0.7.4-1.fc17

17.TC5 x86_64 DVD:

package: PackageKit-zif-0.7.4-1.fc17.x86_64 from myrepo
  unresolved deps: 
     PackageKit = 0:0.7.4-1.fc17

Comment 1 Adam Williamson 2012-05-13 00:44:43 UTC
we requested 0.7.4-2.fc17 for TC5, so I guess somehow the zif subpackage didn't get on the DVDs? Or did both PackageKit-zif-0.7.4-1.fc17 and PackageKit-zif-0.7.4-2.fc17 wind up on there?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Richard Hughes 2012-05-14 08:22:51 UTC
Can we get a package list of the things on the DVD? Thanks.

Comment 3 Andre Robatino 2012-05-14 08:33:25 UTC
Created attachment 584285 [details]
output of "ls *" in the Packages/ directory

Comment 4 Andre Robatino 2012-05-14 08:36:28 UTC
The above list is for i386. I can also provide output for x86_64 if necessary (though I doubt it since it looks like the breakage is the same for both arches).

Comment 5 Kalev Lember 2012-05-14 08:54:35 UTC
Looks like a failure with mash and/or side repos used for pulling in extra packages to the compose. Likely to get fixed with next stable push that includes the PackageKit 0.7.4-2 build.

Comment 6 Adam Williamson 2012-05-14 15:42:13 UTC
Note the presence of both 0.7.4-1 and 0.7.4-2 RPMs for PK itself.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Tim Flink 2012-05-14 18:47:30 UTC
Discussed at the 2012-05-14 mini blocker review meeting. Accepted as a blocker for Fedora 17 final due to violation of the following Fedora 17 alpha release criterion [1]:

"There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"

[1] http://fedoraproject.org/wiki/Fedora_17_Alpha_Release_Criteria

Comment 8 Andre Robatino 2012-05-16 06:07:08 UTC
Fixed in 17.TC6. No repoclosure problems.


Note You need to log in before you can comment on or make changes to this bug.