Bug 821134 - [abrt] libreoffice-ure-3.5.2.1-6.fc17: rtl_string_newFromStr: Process /usr/lib64/libreoffice/ure/bin/uno.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-ure-3.5.2.1-6.fc17: rtl_string_newFromStr: Process /usr/li...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
abrt_hash:53c2bf33eae872e3757806710a3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 07:11 EDT by Milan Bouchet-Valat
Modified: 2012-06-08 11:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 11:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.69 KB, text/plain)
2012-05-12 07:11 EDT, Milan Bouchet-Valat
no flags Details
File: maps (20.62 KB, text/plain)
2012-05-12 07:11 EDT, Milan Bouchet-Valat
no flags Details
File: dso_list (4.71 KB, text/plain)
2012-05-12 07:12 EDT, Milan Bouchet-Valat
no flags Details

  None (edit)
Description Milan Bouchet-Valat 2012-05-12 07:11:50 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/../ure-link/bin/uno.bin --quiet --singleaccept -u uno:pipe,name=f8f5595ffdd8ed1ddd5e77865af88d37ef5cbe9d42dea4dd2e14704b6820cc;urp;uno.ComponentContext -env:INIFILENAME=
comment:        Just started LibreOffice for the first time since the upgrade to F17. Note that Writer itself started OK, I didn't notice the crash at all.
crash_function: rtl_string_newFromStr
executable:     /usr/lib64/libreoffice/ure/bin/uno.bin
kernel:         3.3.5-2.fc16.x86_64
pid:            3128
pwd:            /home/milan
remote_result:  NOTFOUND
time:           sam. 12 mai 2012 12:44:37 CEST
uid:            1000
username:       milan
var_log_messages: May 12 12:44:38 milan abrt[3175]: Saved core dump of pid 3128 (/usr/lib64/libreoffice/ure/bin/uno.bin) to /var/spool/abrt/ccpp-2012-05-12-12:44:37-3128 (59482112 bytes)

backtrace:      Text file, 15040 bytes
dso_list:       Text file, 4826 bytes
maps:           Text file, 21117 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/milan/2

core_backtrace:
:9bd18dd2a7a2b1923e3ea6284d0ac46771ebf3a3 0x2acd4 rtl_string_newFromStr libuno_sal.so.3 -
:adc1bda7097f8d0f18b74b89c45f5c027f899735 0xfc5b - binaryurp.uno.so -
:adc1bda7097f8d0f18b74b89c45f5c027f899735 0x13ab6 - binaryurp.uno.so -
:122d3272a41825968325bddc8ff32820754cdef6 0x3eb3e - libuno_cppu.so.3 -
:122d3272a41825968325bddc8ff32820754cdef6 0x3f2b6 - libuno_cppu.so.3 -
:122d3272a41825968325bddc8ff32820754cdef6 0x3f399 - libuno_cppu.so.3 -
:9bd18dd2a7a2b1923e3ea6284d0ac46771ebf3a3 0x169cc - libuno_sal.so.3 -
:7909c6de930371191ee0fc0b24f87a1a6df419c3 0x7d14 start_thread libpthread.so.0 -
:5c4f739dadc5059e12de9ba0d1d12a43d2fc86d7 0xf194d clone libc.so.6 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=milan
:GIO_LAUNCHED_DESKTOP_FILE_PID=3077
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/milan/keyring-34o6NO/gpg:0:1
:TERM=dumb
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=9e1782da896cc13ddd95ca060000000c-1336816937.414704-413092867
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/run/user/milan/keyring-34o6NO
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=milan
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64
:SSH_AUTH_SOCK=/run/user/milan/keyring-34o6NO/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1212,unix/unix:/tmp/.ICE-unix/1212
:USERNAME=milan
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:DESKTOP_SESSION=gnome
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin
:MAIL=/var/spool/mail/milan
:QT_IM_MODULE=xim
:PWD=/home/milan
:XMODIFIERS=@im=none
:LANG=fr_FR.utf8
:GNOME_KEYRING_PID=1208
:KDE_IS_PRELINKED=1
:GDM_LANG=fr_FR.utf8
:KDEDIRS=/usr/local:/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=1
:HOME=/home/milan
:XDG_SEAT=seat0
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=milan
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-FkE0b7jF71,guid=44944dd588df75e704229eb500000034
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/milan
:URE_BOOTSTRAP=file:///usr/lib64/libreoffice/program/fundamentalrc
:XAUTHORITY=/var/run/gdm/auth-for-milan-chKoos/database
:CCACHE_HASHDIR=

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 29870                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       29870                29870                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/milan/.xsession-errors
:pos:	9978
:flags:	0102002
:2:/home/milan/.xsession-errors
:pos:	9978
:flags:	0102002
Comment 1 Milan Bouchet-Valat 2012-05-12 07:11:54 EDT
Created attachment 583981 [details]
File: backtrace
Comment 2 Milan Bouchet-Valat 2012-05-12 07:11:58 EDT
Created attachment 583982 [details]
File: maps
Comment 3 Milan Bouchet-Valat 2012-05-12 07:12:01 EDT
Created attachment 583983 [details]
File: dso_list
Comment 4 David Tardon 2012-05-17 01:09:39 EDT
dtardon->sberg: This looks like the same problem you fixed by commit d015384e1d98fe77fd59339044f58efb1ab9fb25 . Can you confirm (or deny) it?
Comment 5 Stephan Bergmann 2012-05-18 04:20:10 EDT
@dtardon, good catch, this indeed looks like <http://cgit.freedesktop.org/libreoffice/core/commit/?id=d015384e1d98fe77fd59339044f58efb1ab9fb25> "Fixed ThreadPool (and dependent ORequestThread) life cycle."  I'll see to get it backported.
Comment 6 Caolan McNamara 2012-06-08 11:06:55 EDT
This is now fixed in upstream 3-5 branch. We'll pick it up on bump to 3.5.5 when that's released
Comment 7 Stephan Bergmann 2012-06-08 11:10:16 EDT
This should be fixed with <http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=b7721ccca2f76c52dd6c6bb9b8f673fb276fea52> "Better fix for ThreadPool/ORequestThread life cycle" in upstream libreoffice-3-5, going into upstream's next LibreOffice 3.5.5.

Note You need to log in before you can comment on or make changes to this bug.