Bug 821145 - Wake-on-LAN from S5 using "magic" packet does not work
Wake-on-LAN from S5 using "magic" packet does not work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 09:43 EDT by Armands Liepins
Modified: 2013-07-31 19:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 19:34:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armands Liepins 2012-05-12 09:43:58 EDT
Description of problem:
When system is powered down with the poweroff utility, it can't be waked up with the magic packet anymore. This worked fine before on Fedora 14 with kernel 2.6.35.11-83.fc14.i686.

Version-Release number of selected component (if applicable):
kernel-3.3.4-5.fc17.i686.PAE

How reproducible:
always

Steps to Reproduce:
1. Shutdown with poweroff
2. Send WoL packet
  
Actual results:
System remains powered off

Expected results:
System powers on

Additional info:
# lspci
02:03.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
        Subsystem: 3Com Corporation 3C905CX-TX/TX-M Fast Etherlink for PC Management NIC
        Kernel driver in use: 3c59x

# cat /etc/modprobe.d/network.conf
options 3c59x global_enable_wol=1

# ethtool eth0
Supports Wake-on: g
Wake-on: g

The NIC is still powered when system powers off
Comment 1 Armands Liepins 2012-05-12 09:54:55 EDT
motherboard: Gigabyte GA-8IG1000
http://www.gigabyte.com/products/product-page.aspx?pid=1654#sp
Comment 2 Armands Liepins 2012-05-12 10:18:33 EDT
Tried with Intel EtherExpress PRO/100+, works. Something wrong with the 3c59x driver?
Comment 3 Armands Liepins 2012-05-12 11:01:08 EDT
Found this old conversation:
http://osdir.com/ml/linux.drivers.vortex.devel/2005-06/msg00001.html

created script with "ifconfig eth0 down" in /lib/systemd/system-shutdown and it works now. So, what is the correct solution for this?
Comment 4 Armands Liepins 2012-05-12 14:39:23 EDT
Switching from NetworkManager to network service fixes the problem. On f14 network service were used too. Seems NetworkManager does not use ip tool to bring interface down, it calls nmcli and then exits. Don't know what exactly nmcli does.
Comment 5 Dan Williams 2012-05-15 23:34:56 EDT
So it seems that the NIC doesn't respond to WoL packets when it's been left 'UP'?  That seems pretty wrong, though perhaps we can down the interface when NM goes to sleep and up it when we come back.  The problem with taking interfaces down is that in that state, they don't do link-detection.  That's likely not a problem while sleeping.

In any case, I'd like to confirm this is expected behavior for the NIC driver you're using.  Like you said, e100 seems fine, but 3c59x seems busted here.  This pretty clearly seems like a kernel-side issue given that the interface should be the same between drivers.
Comment 6 Fedora End Of Life 2013-07-03 18:00:00 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Fedora End Of Life 2013-07-31 19:34:59 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.