Bug 821159 - Unable to create GRE tunnel: Address family not supported by protocol
Unable to create GRE tunnel: Address family not supported by protocol
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openvswitch (Show other bugs)
17
All Linux
high Severity high
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 11:45 EDT by Edouard Bourguignon
Modified: 2012-06-19 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 19:40:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2012-05-12 11:45:49 EDT
Description of problem:
When trying to create a GRE tunnel between two ovs-vswitchd, no GRE traffic is generated, GRE interface seems to be disabled.


Version-Release number of selected component (if applicable):
openvswitch-1.4.0-5.fc17.x86_64

How reproducible:
static

Steps to Reproduce:
1. yum install openvswtich
2. service openvswitch start
3. ovs-vsctl add-br br0
4. ovs-vsctl \
-- --id=@i create interface name=gre0 type=gre \
options="remote_ip=192.168.122.201,local_ip=192.168.122.202,key=1" \
-- --id=@p create port name=gre0 interfaces=[@i] \
-- add bridge br0 ports @p

  
Actual results:
May 12 17:32:55|00032|dpif|WARN|system@br0: failed to add gre0 as port: Address family not supported by protocol
May 12 17:32:55|00033|bridge|WARN|gre0 port has no interfaces, dropping
May 12 17:32:55|00034|bridge|INFO|destroyed port gre0 on bridge br0
May 12 17:32:55|00035|bridge|WARN|bridge br0: using default bridge Ethernet address 3a:46:68:e4:a2:4d

Kernel Gre module is not loaded since ovs uses its own implementation.

Expected results:
gre interface/port in ovs should be working


Additional info:
tcpdump shows no GRE traffic
Comment 1 Edouard Bourguignon 2012-05-17 05:52:11 EDT
Hello?

I'm using openvswitch for a couple of years on RHEL and it's the first time I get this error. Any idea?
Comment 2 Edouard Bourguignon 2012-05-28 06:21:47 EDT
Anyone here?
Comment 3 Chris Wright 2012-06-19 19:40:18 EDT
The Fedora Open vSwitch kernel module is directly from upstream Linux which does not (yet) support tunnelling mode.

Note You need to log in before you can comment on or make changes to this bug.