Bug 821166 - Nautilus File Operations progress bar hangs
Nautilus File Operations progress bar hangs
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 12:56 EDT by Joe Sislow
Modified: 2015-08-28 04:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 17:59:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Sislow 2012-05-12 12:56:28 EDT
Description of problem:
When copying files across NFS mounted drives, the progress bar on the File Operations screen does not properly reflect the status.  Basically, it appears that the file copy goes too fast on the progress bar, then the progress bar sits unmoving until the copy actually completes.  The odd thing is that the calculation of transfer rate is correct.  The worst part of this bug is that on a very large file transfer (say, 1GB), it can sit with 100% complete for a LONG time.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Mount a NFS4 drive
2. Select 5 larger files ( < 100 MB) to copy from local drives to NFS share
3. Open up System Monitor, and make sure you note network history
4. Drag the files from the local drive to the shared drive
5. Watch the progress bar speed up then stop to wait for file to actual copy
6. Note sending progress in Network History as file actually copies

Actual results:
Progress bar sits at complete when file isn't actually complete.

Expected results:
Progress bar should reflect actual copying status, as is shown on the System Monitor, as opposed to perhaps the copy into a buffer status that it must be monitoring.  

Additional info:
In case this is a speed issue, I'm running a quad core x86_64 CPU.  Unsure if this is merely related to a mount, but I'm guessing it's a speed issue, not an NFS/NFS4 issue, as the System Monitor can clearly show how much data has been copied.  I haven't yet tested with a large file copying from 2 internal drives.
Comment 1 Fedora End Of Life 2013-01-16 13:58:17 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora End Of Life 2013-02-13 17:59:32 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 3 François 2015-08-28 04:38:29 EDT
I can reproduce this exact bug using Nautilus 3.16.2 on Fedora 22.

Actually, I have been using Fedora since version 21 and have never been able to copy a large file from my hard drive to a USB stick without having this bug.

I tried different the formats with my USB sticks (FAT, NTFS and ext4) I always have the same result. The progress bar goes quickly to 100% and hangs there until the copy has completed.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.