Bug 821172 - VM network name should be limited to 15 chars (because of Linux bridge limits)
VM network name should be limited to 15 chars (because of Linux bridge limits)
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: lpeer
Martin Pavlik
network
:
Depends On:
Blocks: 827870
  Show dependency treegraph
 
Reported: 2012-05-12 14:46 EDT by lpeer
Modified: 2016-02-10 14:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 827870 (view as bug list)
Environment:
Last Closed: 2012-08-30 06:40:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lpeer 2012-05-12 14:46:05 EDT
Description of problem:

The name of a VM network is limited to 20 chars today but should be limited to 15 characters.
The current implementation creates Linux bridge (which is limited to 15 chars) using the name of the network.
I would add validation for the input but not change the DB scheme,mostly because not all networks require bridge.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Kaul 2012-05-13 01:02:41 EDT
I think the limitation should be that the first 15 chars string should be unique, not limited so much in length. (see example in Bugzilla, with its annoying 20 chars limitation for a bug alias).

Example:
vlan161_office-and-it-network
vlan162_qa-and-rnd-network

would be ok with my suggestion, truncated in yours (or disallowed).
Comment 4 lpeer 2012-08-30 06:39:52 EDT
We are not sure if the right solution for this bug is to make the 15 first characters unique or differentiate between the Linux bridge name (which is the reason for this limitation) and the network name.
Comment 5 lpeer 2012-08-30 06:40:43 EDT
This bug won't make it to 3.1, and since the required behaviour is not clear, closing it for now.

Note You need to log in before you can comment on or make changes to this bug.