Bug 821174 - While upgrading to Fedora 17 from Fedora 16 via yum, yum ended before it was finished and I cannot yum-complete-transaction
While upgrading to Fedora 17 from Fedora 16 via yum, yum ended before it was ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 14:49 EDT by Tim Zorn
Modified: 2014-01-21 18:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 12:58:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yumlog (153.47 KB, text/plain)
2012-05-12 14:49 EDT, Tim Zorn
no flags Details

  None (edit)
Description Tim Zorn 2012-05-12 14:49:45 EDT
Created attachment 584062 [details]
yumlog

Description of problem:

I upgraded from 16 to 17 via yum. Yum ended because the system rebooted.
Stupidly I went into rescue mode and reinstalled the kernel.
Now, when I run yum-complete-transaction it fails (log attached)

Version-Release number of selected component (if applicable):


How reproducible:

unkown


Steps to Reproduce:
1. upgrade 16 -> 17 via yum
2. system reboots before complete
3. boot
  
Actual results:

boots into dracut instead of Fedora 17

Expected results:

---

Additional info:

yumlog is log.log for: yum-complete-transaction -d 7 -v > log.log
Comment 1 James Antill 2012-05-14 12:58:14 EDT
 Don't upgrade to F17 using plain yum, use media or preupgrade.

 y-c-t is failing because it can't resolve what to do. You can try using "history redo" or manually installing/reinstall things.

Note You need to log in before you can comment on or make changes to this bug.