Bug 821175 - FC17-Beta install on Acer Ferrari 4005 requires b43.blacklist=yes
FC17-Beta install on Acer Ferrari 4005 requires b43.blacklist=yes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: b43-openfwwf (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 14:50 EDT by eponymousalias
Modified: 2012-06-02 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: F17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 22:57:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eponymousalias 2012-05-12 14:50:49 EDT
Description of problem:
Installation of FC17-Beta from the 64-bit DVD iso doesn't work on an Acer Ferrari 4005 without extra user intervention.  Specifically, you must interrupt the boot process, find the boot line, and add the following parameter at the end, surrounded by spaces: b43.blacklist=yes

Without this parameter, the install hangs with the following messages:
b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy0 ERROR: FIrmware file "b43-open/ucode5.fw" not found
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.

But of course, those instructions are useless pre-install, as they describe actions to take post-install, and the install blocks at this point.  Even worse, there is no hint about the b43.blacklist=yes parameter needed during the install to get past this point.  I only found out about it because I had earlier tried to install Ubuntu 12.04, and faced a similar problem there.  Investigating in the Ubuntu world, I found these pages to be of help:
http://ubuntuforums.org/showthread.php?p=11894350
http://ubuntuforums.org/showthread.php?t=1966655
particularly the latter.

The FC17 install ought to at least hint that the b43.blacklist=yes parameter is necessary to get the install to run.


Version-Release number of selected component (if applicable):
FC17-beta


How reproducible:
Always.


Steps to Reproduce:
1. Try installing from 64-bit DVD iso on an Acer Ferrari 4005.

  
Actual results:
See description above.


Expected results:
The install should either mention the b43.blacklist=yes parameter and pause forever at that point, as it does now (perhaps after printing the ucode messages it presently does), or it should pause for about 30 seconds (long enough for the administrator to read the ucode messages) and then automatically impose the b43.blacklist=yes parameter on the boot, so no obscure and undocumented user intervention is needed during the install process itself.
Comment 1 eponymousalias 2012-06-02 22:57:41 EDT
This issue does not show up when installing the F17 final release on an Acer Ferrari 4005, so I'm changing the status to Closed.

Note You need to log in before you can comment on or make changes to this bug.