Bug 821192 - QA builds: Requires: libcrypto.so.6()(64bit) on Fedora 16
QA builds: Requires: libcrypto.so.6()(64bit) on Fedora 16
Status: CLOSED NEXTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
3.3-beta
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 19:09 EDT by Simon Schönbeck
Modified: 2012-10-11 04:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 04:10:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Schönbeck 2012-05-12 19:09:28 EDT
Description of problem:

When installing 3.3-beta QA builds on Fedora 16 installation fails due to missing dependency of libcrypto.so.6. The most recent version installed is libcrypto.so.10.

Version-Release number of selected component (if applicable):

glusterfs-fuse-3.3.0qa41-1.x86_64
glusterfs-server-3.3.0qa41-1.x86_64
glusterfs-3.3.0qa41-1.x86_64

How reproducible:

Always

Steps to Reproduce:
1.Download glusterfs Fedora packages of QA builds, tried 41, 40 & 39.
2.Install with yum localinstall
3.Yum fails with "Requires: libcrypto.so.6()(64bit)"
  
Actual results:

Failed installation: Requires: libcrypto.so.6()(64bit)
yum install glusterfs-*3.3.0qa41-1.x86_64.rpm
Examining glusterfs-3.3.0qa41-1.x86_64.rpm: glusterfs-3.3.0qa41-1.x86_64
Marking glusterfs-3.3.0qa41-1.x86_64.rpm to be installed
Examining glusterfs-fuse-3.3.0qa41-1.x86_64.rpm: glusterfs-fuse-3.3.0qa41-1.x86_64
Marking glusterfs-fuse-3.3.0qa41-1.x86_64.rpm to be installed
Examining glusterfs-server-3.3.0qa41-1.x86_64.rpm: glusterfs-server-3.3.0qa41-1.x86_64
Marking glusterfs-server-3.3.0qa41-1.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package glusterfs.x86_64 0:3.3.0qa41-1 will be installed
--> Processing Dependency: libcrypto.so.6()(64bit) for package: glusterfs-3.3.0qa41-1.x86_64
---> Package glusterfs-fuse.x86_64 0:3.3.0qa41-1 will be installed
--> Processing Dependency: libcrypto.so.6()(64bit) for package: glusterfs-fuse-3.3.0qa41-1.x86_64
---> Package glusterfs-server.x86_64 0:3.3.0qa41-1 will be installed
--> Processing Dependency: libcrypto.so.6()(64bit) for package: glusterfs-server-3.3.0qa41-1.x86_64
--> Finished Dependency Resolution
Error: Package: glusterfs-fuse-3.3.0qa41-1.x86_64 (/glusterfs-fuse-3.3.0qa41-1.x86_64)
           Requires: libcrypto.so.6()(64bit)
Error: Package: glusterfs-server-3.3.0qa41-1.x86_64 (/glusterfs-server-3.3.0qa41-1.x86_64)
           Requires: libcrypto.so.6()(64bit)
Error: Package: glusterfs-3.3.0qa41-1.x86_64 (/glusterfs-3.3.0qa41-1.x86_64)
           Requires: libcrypto.so.6()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:

Should install cleanly requiring dependencies available in Fedora 16 base & updates repo only.

Additional info:

- libcrypto.so.10 is the version available on Fedora 16.

- 3.3-beta3 does correctly require libcrypto.so.10
Comment 1 hi trends 2012-07-22 20:09:36 EDT
Having the same problem with the stable version (glusterfs-3.3.0-1.x86_64.rpm on fedora 17 64bit). Tried creating a link for libcrypto.so.6 but still got the same error. Is there a work around.
Comment 2 Niels de Vos 2012-10-11 04:10:43 EDT
Please use the packages from http://repos.fedorapeople.org/repos/kkeithle/glusterfs/ if you want to try a later version.

The workaround would be to rebuild the packages from the .src.rpm with a command like

$ rpmbuild --rebuild glusterfs-3.3.0-1.src.rpm

or use 'mock' instead to rebuild in a dedicated chroot environment.


The plan is to provide a fedora repository on download.gluster.org. This will likely have the same contents as http://repos.fedorapeople.org/repos/kkeithle/glusterfs/ .

Note You need to log in before you can comment on or make changes to this bug.