Bug 821204 - Wrong ownership of /var/run/munin
Wrong ownership of /var/run/munin
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: munin (Show other bugs)
el6
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 23:44 EDT by Thomas Bellman
Modified: 2012-07-30 15:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-27 03:22:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Bellman 2012-05-12 23:44:10 EDT
Description of problem:

The update to munin 1.4.7-3.el6 changed ownership of /var/run/munin from
munin:munin to root:root.  This breaks the munin cron job (/etc/cron.d/munin),
as it is run as user munin, and munin-update wants to create a lock file
there.

Every five minutes, I got an error mail saying:

    Creating lock /var/run/munin/munin-update.lock failed: Permission denied
     at /usr/share/perl5/vendor_perl/Munin/Master/Update.pm line 128

Workaround is easy: just 'chown munin:munin /var/run/munin' (or the
equivalent in Puppet, which is what I actually have done).


Version-Release number of selected component (if applicable):

1.4.7-3.el6


How reproducible:

Easily.


Steps to Reproduce:

1. Enable EPEL on CentOS 6.2
2. yum install munin-1.4.7-3.el6
3. Wait five minutes, then check the mail sent to root.

  
Actual results:

A mail is sent to root with the error message show above.


Expected results:

No error mail should be sent.


Additional info:

Presumably, the line

    %dir %{_localstatedir}/run/%{name}/

in the "%files common" section in the spec file should specify that the
directory should be owned by user and group munin.  In the 1.4.7-1 spec
file, that is done in the %files section for the "munin" package, but
that line was removed for 1.4.7-3, without moving the ownership setting
over to the "munin-common" package.
Comment 1 Kevin Fenzi 2012-05-13 11:22:33 EDT
Ugh. Sorry about this. 

I messed it up in my cleanup for several other bugs. ;( 

Will get a new batch of updates out soon... karma and testing very welcome.
Comment 2 Fedora Update System 2012-05-13 11:49:57 EDT
munin-1.4.7-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-1.4.7-4.fc17
Comment 3 Fedora Update System 2012-05-13 11:58:40 EDT
munin-1.4.7-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-1.4.7-4.fc16
Comment 4 Fedora Update System 2012-05-13 12:07:59 EDT
munin-1.4.7-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/munin-1.4.7-4.fc15
Comment 5 Fedora Update System 2012-05-13 12:17:31 EDT
munin-1.4.7-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-1.4.7-4.el6
Comment 6 Fedora Update System 2012-05-13 12:29:03 EDT
munin-1.4.7-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-1.4.7-4.el5
Comment 7 Thomas Bellman 2012-05-13 14:03:42 EDT
I did a brief test of updating to the -4 RPMs from Koji, and saw no ill
effects (i.e., that version seems to work properly).

I tried upgrading both from -1 and from -3.  Upgrading from -1 restored
/etc/munin/plugins as intended, and in both cases I get proper ownership
of /var/run/munin.  (All tests performed on CentOS 6.2 x86_64 with all
updates.)

Thanks for the quick response!
Comment 8 Fedora Update System 2012-05-13 20:42:12 EDT
Package munin-1.4.7-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing munin-1.4.7-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7809/munin-1.4.7-4.fc17
then log in and leave karma (feedback).
Comment 9 Adam Pribyl 2012-05-14 03:58:20 EDT
Looks OK on F15, just I am not getting the update thru updates-testing. Karma added. 

Just a side note - would it not be wise to consider a /var/www/munin/.htaccess a config file? It rewrites my changes on every update.. I may create a separate bug for that for sure, but it probably needs some discussion.
Comment 10 Kevin Fenzi 2012-05-14 10:24:16 EDT
We could. Do file another bug on it so we can get it changed.
Comment 11 Fedora Update System 2012-05-19 12:27:26 EDT
munin-1.4.7-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-1.4.7-5.fc17
Comment 12 Fedora Update System 2012-05-19 12:29:57 EDT
munin-1.4.7-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-1.4.7-5.fc16
Comment 13 Fedora Update System 2012-05-19 12:34:42 EDT
munin-1.4.7-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/munin-1.4.7-5.fc15
Comment 14 Fedora Update System 2012-05-19 12:37:35 EDT
munin-1.4.7-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-1.4.7-5.el6
Comment 15 Fedora Update System 2012-05-19 12:40:19 EDT
munin-1.4.7-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-1.4.7-5.el5
Comment 16 Fedora Update System 2012-05-27 03:22:45 EDT
munin-1.4.7-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-05-27 21:24:37 EDT
munin-1.4.7-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-05-27 21:26:11 EDT
munin-1.4.7-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-06-03 14:30:11 EDT
munin-1.4.7-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-06-03 14:31:13 EDT
munin-1.4.7-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Manuel Schilt 2012-07-29 08:41:38 EDT
Problem still persist in munin-1.4.7-5.fc16.noarch

chown root:munin /var/run/munin
chmod 775 /var/run/munin

solved the problem.
Comment 22 Kevin Fenzi 2012-07-30 15:50:23 EDT
This might be another case of 834055

Note You need to log in before you can comment on or make changes to this bug.