Bug 821207 - Re-enable winepulse (1.5.4 patch[s] attached)
Re-enable winepulse (1.5.4 patch[s] attached)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
1.5.5
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 00:24 EDT by Gilboa Davara
Modified: 2012-07-14 17:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 16:53:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wine 1.5.4 wine-pulse patch. (106.27 KB, patch)
2012-05-23 07:36 EDT, Gilboa Davara
no flags Details | Diff
wine 1.5.4 wine-pulse SPEC patch. (1.65 KB, patch)
2012-05-23 07:37 EDT, Gilboa Davara
no flags Details | Diff

  None (edit)
Description Gilboa Davara 2012-05-13 00:24:27 EDT
Since the rewrite of mmdevapi and the drop of the winepulse patch I've been suffering from severe audio issues under wine (as many others) [1].
Wine devs already stated that trying to get mmdevapi over Alsa-plugin over PA didn't really work out [2].
Official PA support is planned but no target release date / version is set.
Seems that winepulse is alive and well [3].
I've built it * and used it in a number of Windows applications and it seems to work just fine.

- Gilboa
[1] http://bugs.winehq.org/show_bug.cgi?id=28622
[2] http://bugs.winehq.org/show_bug.cgi?id=10495
[3] http://repo.or.cz/w/wine/multimedia.git
* Diff the official trunk and winepulse trunk and added the diff to the F16 SRPMS without any issues.
Comment 1 Gilboa Davara 2012-05-23 07:36:48 EDT
Created attachment 586317 [details]
wine 1.5.4 wine-pulse patch.
Comment 2 Gilboa Davara 2012-05-23 07:37:31 EDT
Created attachment 586318 [details]
wine 1.5.4 wine-pulse SPEC patch.

Tested (briefly) on F16/x86_64. Sounds looks OK.
Comment 3 Gilboa Davara 2012-05-28 06:14:19 EDT
Short update:
Tested it thoroughly during the weekend, worked perfectly.


- Gilboa
Comment 4 Fedora Update System 2012-07-05 11:57:29 EDT
wine-mono-0.0.4-7.fc17,wine-1.5.8-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wine-mono-0.0.4-7.fc17,wine-1.5.8-1.fc17
Comment 5 Fedora Update System 2012-07-05 11:59:49 EDT
wine-1.5.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wine-1.5.8-1.fc16
Comment 6 Gilboa Davara 2012-07-06 08:46:17 EDT
No way to satisfy wine-mono in-order to test this build under F17.

- Gilboa
Comment 7 Fedora Update System 2012-07-06 17:29:28 EDT
Package wine-mono-0.0.4-7.fc17, wine-1.5.8-1.fc17, mingw-wine-gecko-1.6-1.fc17, mingw-crt-2.0.999-0.6.trunk.20120601.fc17, mingw-headers-2.0.999-0.6.trunk.20120601.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-mono-0.0.4-7.fc17 wine-1.5.8-1.fc17 mingw-wine-gecko-1.6-1.fc17 mingw-crt-2.0.999-0.6.trunk.20120601.fc17 mingw-headers-2.0.999-0.6.trunk.20120601.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10358/mingw-wine-gecko-1.6-1.fc17,mingw-crt-2.0.999-0.6.trunk.20120601.fc17,mingw-headers-2.0.999-0.6.trunk.20120601.fc17,wine-mono-0.0.4-7.fc17,wine-1.5.8-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-07-10 16:53:23 EDT
wine-mono-0.0.4-7.fc17, wine-1.5.8-1.fc17, mingw-wine-gecko-1.6-1.fc17, mingw-crt-2.0.999-0.6.trunk.20120601.fc17, mingw-headers-2.0.999-0.6.trunk.20120601.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Gilboa Davara 2012-07-11 05:13:17 EDT
Seems to be working just fine. Thanks.

- Gilboa
Comment 10 Fedora Update System 2012-07-14 17:58:51 EDT
wine-1.5.8-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.